How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask HDGENE Your Own Question
HDGENE
HDGENE, Ford Senior Master/Diesel/Trans
Category: Ford
Satisfied Customers: 4915
Experience:  25 years Auto experience, Ford ,GM, Chrysler, Asian & European
285738
Type Your Ford Question Here...
HDGENE is online now
A new question is answered every 9 seconds

I have a 2005 ford ranger just changed transmission wich was

Customer Question

I have a 2005 ford ranger just changed transmission wich was a 2006 it is automatic it wont go into overdrive and od light comes on the code said incorrect gear ratio for 5th how can i fix this
Submitted: 1 year ago.
Category: Ford
Expert:  HDGENE replied 1 year ago.

hello, did you use a used transmission and what problem did you have with the old trans which lead to replacement?

Customer: replied 1 year ago.
i did use used tranny and the old one was skipping to get into 4th and the rpms would go real high and skip to get into overdrive so i called a specialist and he told me it wasnt worth fixing and to get another one and this one wont go into overdrive and overdrive off light keeps blinking and when i shut it off it resets and does it all over again
Expert:  HDGENE replied 1 year ago.

Ok and all you are getting is a code P0735 for a 5th gear ratio fault or you have other codes as well?

Customer: replied 1 year ago.
I dont know about any other codes i took it to advance and they put their gun on it and that is all that came up was incorrect 5rh gear ratio
Expert:  HDGENE replied 1 year ago.

Ok, then here is the issue. The used trans you installed has a problem with the overdrive band servo piston that applies the band. The case bore the servo piston slides backin forth in is messed up. There is a repair kit out to drill out the old bore and install a wear sleeve to fix this, but it requires removal of the trans like an overhaul to do so. The servo piston gets stuck inside the bore and cant apply the band properly.

Customer: replied 1 year ago.
Will it mess up anything if i drive it like that
Customer: replied 1 year ago.
is it possible that one of the sensors are bad
Customer: replied 1 year ago.
He did not change the sensors
Expert:  HDGENE replied 1 year ago.

No, if you had an issue with a speed sensor, it would set a seperate code for it and would have more than one gear ratio fault. Since its one gear only, the problem is in the trans.

Expert:  HDGENE replied 1 year ago.

hello, do you need more help with this concern? If I was helpful please hit accept and leave a positive rating so I get credit for assisting you.