How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 44531
Experience:  16 years experience
2499435
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

2003 F350 5.4L will not start after replacement of 20AMP

Customer Question

2003 F350 5.4L will not start after replacement of 20AMP Turn Signal Fuse.
Makes no sense!!!
Submitted: 1 year ago.
Category: Ford
Customer: replied 1 year ago.
I reviewed all fuses after replacement of the 20AMP turn signal fuse. I checked all of the relays based on the fuse schematic.
Ignition switch does not click, power supply on battery appears sufficient to turn over. I drove the truck several times today including to buy a relay - but did not need to install after locating the fuse (turn signal and flasher fuse).
Expert:  Chris (aka- Moose) replied 1 year ago.

Welcome I'm Chris aka Moose

Can I assume this fuse was blown?

Did you repair the circuit that was damaged and caused this fuse to fail?

-----------About me and Just Answer------------

I am in my upper 30's, have a wife and 2 sons. I farm, fish, hunt, build, and coach youth soccer. I work on anything with an engine, been to many schools and classes through my 12 years with the dealership to get trained and certified. I try the best I can to share what I know and or have access to with my customers. Please consider I base my questions and answers to you, solely on the information you give me since I am not there to see, smell, hear, touch, or test. I try my best to be here everyday starting at 3pm central. Rating an answer is required. Please let me know if your not pleased prior to rating or if you cannot rate me so I can try to help a different way. God Bless and have a great day.

Thanks Chris

Customer: replied 1 year ago.
I may have found the short from the camper shell light that was touching the left rear tail gate. The ignition will still not turn over. I noticed two things when turning the key over, a small instrument "icon" that looks like a bolt coming out of the side of the truck in yellow appears for 5 seconds and the disappears. The Engine compartment makes a short 2 second groan like a pneumatic sound. I think the issues are now down to three possibilities:
1. Starter Relay (Fuse box - location 307)
2. Starter Solenoid / Starter
3. I have no idea
Customer: replied 1 year ago.
I am leaning towards the starter solenoid being shorted from the grounding of the truck shell light wire (hot - positive lead ) that had contact with the bed. I have looked at every fuse in the panel under steering - looking at individual fuses under the dash and inside the firewall of the truck - they all look like G.M. style fuses (large).
Customer: replied 1 year ago.
Found the problem - ECM wires - two were just loose from the base unit. I must have bumped them loose while searching for the short from the turn signal wire.
Expert:  Chris (aka- Moose) replied 1 year ago.

Glad you found the issue. Being you have paid for answer but solved it yourself, do you have another concern I can help with?

Customer: replied 1 year ago.
No I am OK with the process and will be asking again soon as I am sure there will be another part or performance question.\
Thank you,
James
Expert:  Chris (aka- Moose) replied 1 year ago.

Since there was no rating the deposit you made will remain in your account available to use here for a while.

Related Ford Questions