How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask James Your Own Question
James
James, Ford Technician
Category: Ford
Satisfied Customers: 3611
Experience:  Ford Senior Master Tech, Ford gas and diesel expert, ASE Certified
74859263
Type Your Ford Question Here...
James is online now
A new question is answered every 9 seconds

02 explorer 87,000 miles car has interrmittent stumble some

Customer Question

02 explorer 87,000 miles car has interrmittent stumble some days it does it some it dont no light when it does do it cruise wont engage at all when its running fine cruise works as well?
Submitted: 1 year ago.
Category: Ford
Expert:  James replied 1 year ago.

Hello, did you replace spark plug wires as well?

Customer: replied 1 year ago.
Customer: replied 1 year ago.
The cruise control doesnt engage when car is acting up took a two hour trip this past weekend acted up whole way cruise would mot engage came back cruise engaged and car ran fine
Expert:  James replied 1 year ago.

Does the overdrive light flash at all or check engine light?

Customer: replied 1 year ago.
No od light no codes or check engine light
Customer: replied 1 year ago.
I was wondering if this could possibly be caused by vaccuum leak to affect performsnce and cruise?
Expert:  James replied 1 year ago.

It could be caused by a vacuum leak should be present at idle as well.

Customer: replied 1 year ago.
There is a little rumble at idle not much
Customer: replied 1 year ago.
More like slight shake
Expert:  James replied 1 year ago.

I would clean the throttle body very good and once that is done disconnect the battery for ten minutes and drive the vehicle. This should correct the concern for you.

Customer: replied 1 year ago.
I also have a hissing noise when you turn car off with ac in off position
Expert:  James replied 1 year ago.

If the hissing noise only lasts a couple seconds that can be normal. If it was a vacuum leak it would hiss the entire time except when you shut the engine off.