How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 47332
Experience:  16 years experience
2499435
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

2000 ford ranger gas engine no speedometer od light flashing

Customer Question

2000 ford ranger gas engine no speedometer od light flashing harsh shifting auto trans
Submitted: 1 year ago.
Category: Ford
Expert:  Chris (aka- Moose) replied 1 year ago.

Your truck can have 2 or 4 wheel ABS. Below are 2 links for both wire diagrams.

We need to unplug the rear axle speed sensor and the GEM module or the ABS module. OHM test both speed sensor wires from both ends to see if the wires are broken. Then OHM test them together to see if they are shorted to each other. Then from either end OHM test both wires to both battery posts to see if the wires are shorted to anything else. Your readings for each test should be 0.0, 0.0, OL out of limits, OL, and OL. If this is what you get then the wiring to the sensor is fine.The sensor is new, so its fine.

That means its either module depending on the setup you have or the wire from the module to the PCM and instrument cluster. So next you need to OHM test that wire to only see if its broken. If its fine then its the module to blame, for not making a VSS signal.

You want a excellent 5 star answer & I would like to be rated the same for providing it. Consider I don't know your skill level & I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies. Try your best to respond with good detail so I can do the same. I normally log in at 3pm and work late. A rating is required. Your rating me, what I type. I am not an employee of this website, nor have control over the fees or the time it took to get a response. If you rate negative or not at all you still paid, but I get nothing. I want you pleased with me and my efforts, so let me know if your experience here has come up short.

Thanks Chris

Customer: replied 1 year ago.
I have your answer and it sounds good however I am being told that it is probably the trans internal speed sensor can you help don
Expert:  Chris (aka- Moose) replied 1 year ago.

As you can see in the diagrams I sent from Ford, the vehicle speed sensor comes from the rear axle. This signal is used by the PCM, instrument cluster, ABS, and speed control. When this signal is not there, the transmission will shift bad. The TSS sensor inside the transmission, it can be bad, but it will not address the speedometer, that would mean you have 2 issues. Not knowing what codes are stored, I have to base it on the symptoms you mentioned and with the things not working and the lights your getting, its more than likely not a transmission internal nor external issue. Though if you want directions to remove and disassemble the transmission, to replace this sensor, let me know.