How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Auto Service Technician
Category: Ford
Satisfied Customers: 23816
Experience:  25 years experience on all makes and models, Licensed NYS Inspector.
2921078
Type Your Ford Question Here...
Mike V. is online now
A new question is answered every 9 seconds

My 2007 Mustang GT with a 4.6L 3v engine was having

Customer Question

Hi. My 2007 Mustang GT with a 4.6L 3v engine was having intermittent problems. After running for 10-15 minutes, while sitting at a red light the engine would all of a sudden start running like crap and would almost stall out. I though maybe the problem was due to fouled fuel injectors so I added 1/2 litre of fuel injector cleaner and filled the fuel tank. After 4 or 5 days the problem was still the same. Again the engine would run great for 10-15 minutes then all of a sudden it would run like crap until the next cold start. The other day I started it again and it started running like crap right away so the problem is no longer intermittent. I did a bit of diagnostic work and found that the spark plugs were firing on all 8 cylinders so I then checked the fuel injectors and found that there is no power to all (4) injectors on Bank 1. Any thoughts on what the underlying cause may be ?
Thanks,
Bill
Submitted: 1 year ago.
Category: Ford
Expert:  Mike V. replied 1 year ago.

HI Bill,

So the injector has no power or it's not firing?
How are you checking them?

Customer: replied 1 year ago.
Sorry, yes all (4) injectors aren't firing. They were checked with a noise meter. Can smell fuel on the spark plug and there is power to the injectors. The vehicle is actually at a shop but I thought I'd do some research myself and get a second opinion. Thanks for your help.
Expert:  Mike V. replied 1 year ago.

Ok, if the injectors are powering up but not flashing with a noid light, I have to think the issue is the PCM. Since bank 2 is firing as it should, this would mean the computer is seeing the signal to fire off the injectors. If the plugs are getting fuel it's possible the injectors are being stuck open. See, the computer sends the ground to fire the injectors in milliseconds. If they are staying open, then the engine is being flooded with fuel on that bank, and I think either the issue has to be the computer, or the wiring harness on that bank is shorted to ground. That however would mean that all 4 wires would be rubbed through somewhere along the engine and touching the block. This would have to be the cause.

Customer: replied 1 year ago.
I am meeting with the mechanic tomorrow morning so I'll see what their diagnosis is. Will touch base with you later tomorrow. Thanks for your help.
Expert:  Mike V. replied 1 year ago.

Sounds good, hope the problem is found!!

Photo of my 08 enclosed, I know how I would feel if it were my baby :)