How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ray M. Your Own Question
Ray M.
Ray M., Ford Master Tech
Category: Ford
Satisfied Customers: 3019
Experience:  30+ years in trade, Ford Master Tech, Journeyman Automotive Tech
11409661
Type Your Ford Question Here...
Ray M. is online now
A new question is answered every 9 seconds

Have a 2000 7.3 power stoke noticed a couple of times

Customer Question

Have a 2000 7.3 power stoke noticed a couple of times service engine light would come on would run like crapp no power. Before I could stop it went off and ran fine that was a couple of months ago. Then it has been running ok.but when driving now it seemed like the motor would Rev up and the transmission was jumping back and forth. Then it would quit. And wouldn't do it anymore. The accelerate peddle is really touchy. A couple of times I pushed on the peddle and nothing. I let up on it and it would work. But I noticed the truck don't have the giddy up and go that it had. Driving it yesterday the service light came on ran crappie. It went off again ran ok did it 3 times. Then the acceleration started that again. Got home was letting it idle while moving a car out of my spot it died. The wait to start light won't come on checked fuse ok. It will crank but won't start. Have no code reader. Looking for what is wrong with it.
Submitted: 1 year ago.
Category: Ford
Expert:  Ray M. replied 1 year ago.

It sounds like you have what is a common problem with the 7.3l, the connector for the glow plugs and injectors under the valve cover has come apart, ford has a small clip that you install in the connector to prevent this from happening again, to install this clip you need to remove the valve cover. Here is a link to a page that sells them.http://puredieselpower.com/ford/99-03-ford-7.3l-powerstroke-updated-uvc-under-valve-cover-harness-clips.html

Expert:  Ray M. replied 1 year ago.

Hope this helps, let me know if you need more help.

Related Ford Questions