How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

2005 Ford Expedition king ranch 5.4 triton - misfires ,

Customer Question

2005 Ford Expedition king ranch 5.4 triton - misfires , rough idle and stalls , runs fine at and above 2500 rpms. Brakes feel like they are losing vacuum . No vac leaks , checked and changed spark plugs and coils . Fuel filter As well . Trouble codes read
bank 2 lean 1 misfires on 1 and 3 and 4 and 6 , then will change after plugging in 3 different code readers . I have heRd that maybe it's the vcts I unplugged them and no change . I can unplug each coil and there is no change in idle . The suv idles at about
400 to 500 rpms with the a/c running . Have to leave the over drive off to get up to 65 mph or 2500 rpms then can switch it back on . It won't get over 80 to 85 mph . Sometimes it feels like it has absolutely no power and then will surge with full power .
What is the deal ? I have an O2 sensor code Also . Someone rear ended us and after it left the body shop it has ran like this ever since . I'm pretty well mechanicAlly inclined but this is crAzy . Help !!!!!
Submitted: 1 year ago.
Category: Ford
Expert:  Chris (aka- Moose) replied 1 year ago.
Can I get all the code numbers that are currently storing?