How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

F-550: 2014 F-550 tow truck w/V-10 Triton, Transmission-mounted

Customer Question

2014 F-550 tow truck w/V-10 Triton, Transmission-mounted PTO.
Although no driving/engine performance issues, the following occurred: Airbag, battery lights periodically illuminated, plus PTO turning off at random.
Ford technician was dumbfounded, although we collectively confirmed that it was not the: Battery, alternator, or computer, yet Ford had absolutely no clue as to the issue.
Once we pulled truck from Ford, we determined that three small (16 gauge-ish) wires, all collectively crimped to a single connector and attached to the negative terminal of battery were a bit corroded and a few strands broken away. We then stripped back all three to free of corrosion and lost strands, then recrimmped, reconnected. We, then cleaned grounding strap. IT WORKED! We have been trouble-free for a month.
Today, same issue.
Aside from substandard wiring initiative, what could possibly be the issue?
Kindly advise.
Submitted: 1 year ago.
Category: Ford
Expert:  fordtechsuzukitech25 replied 1 year ago.
i think you no the answer(faulty ground) but were, any chance there is a number on the tow truck to see if they can help as to were the wiring runs to and maybe they heard of this concern

Related Ford Questions