How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kenny Z. Your Own Question
Kenny Z.
Kenny Z., Ford Senior Master Tech
Category: Ford
Satisfied Customers: 5267
Experience:  Auto Trans, Drivability and Electrical Specialist
9600325
Type Your Ford Question Here...
Kenny Z. is online now
A new question is answered every 9 seconds

Expedition: Kenny, I am having trouble with the running

Customer Question

Hello Kenny, I am having trouble with the running boards on a Ford Expedition EL King Ranch 2008. The passenger side works perfect. The drivers side works form time to time. Usually will stop working after the car has been idle over night or for some time. When not operable I can here the motor turn on but the step won´t move. When operable It makes a bit of a stutter.
Thank you for your help.
Submitted: 1 year ago.
Category: Ford
Expert:  Kenny Z. replied 1 year ago.
Hello and thanks for your question. Usually this is caused by pivots in the hinges siezing from external contamination, especially is you can hear the motor running when trying to move the board. Unfortunately lubing the hinges does not cure the issue because the lube cannot get far enough into the pins. There are no serviceable parts for the board hinges. The board will need to be replaced.
Expert:  Kenny Z. replied 1 year ago.
If you need more help, please use the reply tab to continue our conversation. If you do not require further assistance, kindly rate my service as you see fit. Rating does not close the question if you have follow up questions. Thanks!