How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask A. Penland Your Own Question
A. Penland
A. Penland, Ford Senior Master Technician, ASE
Category: Ford
Satisfied Customers: 6212
Experience:  ASE Master Certified, ASE Advanced Gasoline Engine Performance
14865528
Type Your Ford Question Here...
A. Penland is online now
A new question is answered every 9 seconds

Yes I just jumped it with my Explorer and at first on clicking

Customer Question

Yes I just jumped it with my Explorer and at first on clicking so I let the Explorer run about 5 minutes and the Expedition cranked....does that eqate to the need for a new battery or an alternator?
Submitted: 1 year ago.
Category: Ford
Expert:  A. Penland replied 1 year ago.
Hello and thanks for using JustAnswer.I will try my best to help you with your question.
Yes, it could be the battery. You can have the proper voltage, but your engine needs CCA (Cold Cranking Amps) to crank the engine over by the starter. I think your battery should be rated at either 650CCA or 750CCA. Have the battery properly load tested to make sure. Any good auto parts store can do this for you for free.

Related Ford Questions