How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23808
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

Expeditions: I have a 200 Expedition...Up until a year it ran

Customer Question

I have a 200 Expedition...Up until a year it ran great.
It now has acceleration, rough riding, shut down issues.
No codes.
Auto mechanic couldn't find the problem. The gas pressure was low so he replaced the fuel pump. He also changed out the alternator, and the computer to troubleshoot, the problem still exists.
Dealer said it was the MAF, I changed it. No change. (250.00)
I looked up information on line and changed the IAC. Little change.
Now mechanic says diagnostic doesnt show anything, and it's probably the computer. Maybe it needs to be re-synced.
Please any help would be appreciated
Submitted: 1 year ago.
Category: Ford
Expert:  A. Penland replied 1 year ago.
Hello and thanks for using JustAnswer.I will try my best to help you with your question.
I just need to know what engine is in your 2000 Expedition?
4.6L or the 5.4L?