How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask HDGENE Your Own Question
HDGENE
HDGENE, Ford Senior Master/Diesel/Trans
Category: Ford
Satisfied Customers: 4784
Experience:  25 years Auto experience, Ford ,GM, Chrysler, Asian & European
285738
Type Your Ford Question Here...
HDGENE is online now
A new question is answered every 9 seconds

Expedition: lost rider. My 2003 expedition charging system

Customer Question

Hi lost rider. My 2003 expedition charging system and battery light flickers intermittenly. Its bginning to get worse. FYI, I just replaced the engine with a used one with 70,000 miles. Any ideas?
Submitted: 1 year ago.
Category: Ford
Expert:  HDGENE replied 1 year ago.
Hello, used engine but original or same altenator? What happened that caused the previous engine to be replaced?
Customer: replied 1 year ago.
The bottom end lost a bearing. And yes, its the same alternator from the old engine
Expert:  HDGENE replied 1 year ago.
Ok, long as the connections are tight and the voltage regularoe connection to the altenator is not melted I would suspect some worn brushes in the altenator or a failing diode trio causing the battery light to start flashing. Double check the belt isnt slipping due to a dragging ac cpmpressor or other front accessory pulley.Most auto parts stores will bench test an altenator but might not fail unless under a heavy load
Customer: replied 1 year ago.
Used engine
Expert:  HDGENE replied 1 year ago.
Long as the engine is running good and what I mentioned looks ok, def suspect a failing altenator
Customer: replied 1 year ago.
Ok. I replaced the alternator and belt, wiring harness is tight and clean of any corrosion. I even used dielectric grease on all connections. Battery and terminal are good. I have same problem. Now what?
Expert:  HDGENE replied 1 year ago.
You have power at the altenator and the voltage regulator?The battery light on the dash comes on when the key is turned to on or does it flicker when the key is turned to on
Customer: replied 1 year ago.
Yes I have all components. The vehicle charges fine but if you go back to my first question, it intermittently shows a battery light that flickers
Expert:  HDGENE replied 1 year ago.
Yes, usually a bad diode trio causes the battery lamp to flicker or a set of work brushes intenal on the voltage regulator. Unless there is an issue with the instrument cluster which would set codes in the cluster since it is a module. Possibilty of a defective altenator new out of the box too depending where you got it and the altenator circuits test ok no short to power.

Related Ford Questions