How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23001
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

Thunderbird: Having kind of the same issue with my 97. I replaced

Customer Question

Having kind of the same issue with my 97. I replaced all o2 sensors, maf, plugs wires ,fuel filter ,coolant temp sensor. Just to find out it was the brain. replaced that lasrt year and it was fine. After 7 monthes the cel came back on for running rich (both banks). can't figure it out. seems to actually be running great accept it started bogging and not wanting to take off from a stop but after a second it surges and takes off fine. drives fine other then that
Submitted: 1 year ago.
Category: Ford
Expert:  EricFromCT replied 1 year ago.
Hi. My name is ***** ***** I will assist you with your concern today. Please rate my assistance after we have concluded chatting.
Have you checked the fuel pressure with a gage?

Related Ford Questions