How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Virtual Wrench Your Own Question
Virtual Wrench
Virtual Wrench, Ford Mechanic
Category: Ford
Satisfied Customers: 14618
Experience:  35 years Master Mechanic
2617050
Type Your Ford Question Here...
Virtual Wrench is online now
A new question is answered every 9 seconds

Ranger: I have a 1990 Ford ranger 4.0 pushrod v6 now I've replaced

Customer Question

I have a 1990 Ford ranger 4.0 pushrod v6 now I've replaced the fuel pump I've replaced the relay I've replaced the pcm and I've replaced the ignition control module but it still won't receive fuel and it's not the interia switch and also when I turn the key to run without starting the vehicle the check engine light does not come on I just really need help with this
Submitted: 1 year ago.
Category: Ford
Expert:  Virtual Wrench replied 1 year ago.
Hi,
First off will it try to start if you spray some starting fluid, or carb cleaner into it?
Expert:  Virtual Wrench replied 1 year ago.
Hi,
Did you still need help with this?
Expert:  Virtual Wrench replied 1 year ago.
I see that you have viewed my last post and i am confused. If you dont need help just say so please.
Customer: replied 1 year ago.
Hey I got it to work
Expert:  Virtual Wrench replied 1 year ago.
Right on! Just wanted to be sure you werent left hanging!
Take care!
LJ
Customer: replied 1 year ago.
Quick question while I have you I've put 2 New transmissions in my Ford and neither of them lasted more than a day because they build to much pressure and pour atf out of the bell housing would you know anything about that
Expert:  Virtual Wrench replied 1 year ago.
Hi,
Did you put a new torque converter in when you replaced the trans?
Customer: replied 1 year ago.
Yes both times
Expert:  Virtual Wrench replied 1 year ago.
The only thing that i have seen happen is the converter gets a groove worn in the part that goes thru the front pump seal and you have to put a "speedy sleeve" on it.
Anytime i have seen any leaking from too much internal pressure is when it comes out the top of the trans vent tube. Thats the FIRST place and excess pressure would leak so i suspect either the converter shaft is worn or someone is not installing the front pump seal correctly.
Customer: replied 1 year ago.
Ok thanks
Expert:  Virtual Wrench replied 1 year ago.
You are welcome.
I sure have put a lot of those sleeves on and they work great even if you think the converter shaft looks good!
If you are satisfied with my service please use the required rating for me to receive credit for working with you.
Customer: replied 1 year ago.
Ok will do
Expert:  Virtual Wrench replied 1 year ago.
Thank you my friend!
Take care now.
Larry
Expert:  Virtual Wrench replied 1 year ago.
Hello,
I notice you have not yet rated my service. Please do so i can receive credit for working with you.
LJ