How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23821
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

Taurus: 2001 Ford Taurus 3.0l OHV Flex Fuel.About a month

Customer Question

2001 Ford Taurus 3.0l OHV Flex Fuel.
About a month ago I had the front of the car up on jack stands for about a week and did a bunch of front end work. New Tie Rods and ends, lower ball joints, new struts and brakes. When the car was all back together I took it for a test drive. The car drove ok at first, but I wasn't doing over 30 mph. I took it out of town and it wouldn't go over 40 mph by the time I got it back home it wouldn't go over 25. Now it struggles to get to 20. It idles fine for the most part. Every once in a while it idles a little rough. The only code I am getting is 0401. I have been getting this code for a year. In the last 2 weeks I have tested the EGR Valve it seems to operate correctly and holds vacuum. I replaced the DPFE and the EGR Solenoid as they both tested bad. They now test good. I have changed the plugs and wires and the fuel filter. The coil pack is about a year old and tests good. I have checked everything I can think to check. I have looked to see if I knocked anything loose or broke any connectors or anything else when I was doing the front end work. Once in a while before I did the front end work the car would seem to run a little off, but nothing major. The PVC valve seems to be fine. The hose is in good shape. I am usually able to track down pretty much any car problem, but am at my wits end. At this point I am thinking possibly catalytic converter(s). Help!
Submitted: 2 years ago.
Category: Ford
Expert:  Kenny Z. replied 2 years ago.

Hello my name is***** and thanks for your question.

Is this a smooth lack of power like a steady bog or is it misfiring and running rough when trying to accelerate? How does it free rev in park if you floor the gas pedal?