How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Edward Your Own Question
Edward, ASE Certified Technician
Category: Ford
Satisfied Customers: 2753
Experience:  ASE certified. Auto Transmission rebuilder for Ford Motor Co. from 91 to 2000
Type Your Ford Question Here...
Edward is online now
A new question is answered every 9 seconds

Ford ranger: starter stays engauged when switch is in the on

This answer was rated:

starter stays engauged when switch is in the on position when in park or neutral. need a wiring schematic.
Hello and thanks for your question. My name is XXXXX XXXXX I will do all I can to help.

I can get you a diagram, thats no problem, Let me first ask, did you swap another relay out for the starter relay (like horn relay or wiper relay) and retest it?
Customer: replied 3 years ago.


No help I take it? not a stuck relay then?
Also, automatic or manual trans.?
Customer: replied 3 years ago.


alright, pull fuse 24 (7.5 amp) out of the fuse box, see if it still does it then.

Here is the diagram. If it doesn't do it then, wire isn't shorted to power from starter motor to the starter fuse in interior fuse box.

Attachment: 2013-07-31_170159_va101835.pdf

hold on, didn't up load right.
There it is, you should see it when you click that link now Randy.
Customer: replied 3 years ago.

Would that also mess with the speedometer and odometer and shifting

I really wouldn't think those two problems are related. Check the codes in the PCM for speed sensor codes.
If it's doing it only in park or neutral, then we know the power source is coming before the MLP switch. the RED/BLUE wire coming right out of the ignition switch, see if it's hot right out of the ignition switch. If it is, You got some wires crossed up on the ign. switch connector or the switch itself is bad, I know you you said you just replaced it, so I can't believe another one would be bad. But, If it's got power on the RED/BLUE wire in P or Neutral, I would suspect it.
Customer: replied 3 years ago.

my helper didn't notice there was an anti theft switch on it. . it does have a vss code too.

Alright, is the starting issue resolved now? VSS should be in the rear differential on the top. Check the harness real good in the plastic loom as well. seen them break in there where they flex everytime the suspension moves.
Customer: replied 3 years ago.

yes. we are check the vss now

Alright, sounds good.
Customer: replied 3 years ago.

abs was the trick. thanks I thought it was but you never know

absolutely, thank you.
Edward and 2 other Ford Specialists are ready to help you