How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bamaman39 Your Own Question
Bamaman39
Bamaman39, Ford Technician
Category: Ford
Satisfied Customers: 2288
Experience:  10 years ford experience, Ford Senior Master Diesel And Gasoline Tech
17239397
Type Your Ford Question Here...
Bamaman39 is online now
A new question is answered every 9 seconds

just finished up an EGR delete kit on an 06 6.0 powerstroke..everything

This answer was rated:

just finished up an EGR delete kit on an 06 6.0 powerstroke..everything is back together but the turbo sounds like it is leaking air and also on a small test drive im not building any boost..maybe 3 psi or so!!!! any help????

Bamaman39 :

Thank you for using just answer. My name is XXXXX XXXXX i will assist you today.

Bamaman39 :

Hello

Customer:

i have a loud hissing noise after installing an EGR delete kit

Customer:

i also need to have this fixed by wednesday..going on vacation

Bamaman39 :

ok

Bamaman39 :

so you put the whole delete kit on

Bamaman39 :

removed the turbo

Customer:

yes..new up pipe, block off plate, and new 180 degree pipe that replaces the old cooler

Bamaman39 :

What has happened is that the turbo is not seated all the way on the Y -pipe. Take the clamp off where on the drivers sde exhaust that goes to the turbo. It must be flush. You may have to take the turbo back off and move the turbo mount some to line it up

Bamaman39 :

I have had this happen to me all the time

Customer:

so its the "Y" pipe to the turbo and not the pipe to the drivers side exhaust manifold?? and the truck is not building up boost at all

Bamaman39 :

The drivers side pipe is called the Y-pipe

Bamaman39 :

The reason you are not building boost is because of the exhaust leak

Customer:

ok..i had my dad helping me and while i was tightening the exhaust manifold bolts from underneath he was putting on the clamp to the turbo!! so just loosen up all clamps and bolts and retry??

Bamaman39 :

Make sure you tighten the turbo clamp first.

Bamaman39 :

Take the clamp loose and se if there is a gap

Customer:

ok..i think thats where are mistake was..tighten the turbo clamp first then tighten the manifold bolts?? is it necessary to loosen the big exhaust clamp to the turbo or those manifold bolts??

Bamaman39 :

loosen the clamp to the ypipe and see if there is a gap

Bamaman39 :

if so try to push it on with a pry bar

Bamaman39 :

if that does not work then take the bolts loose at the bottom and tighten the top clamp first when the pipe is flush

Bamaman39 :

If the pipe will not line up then the turbo mount is on the wrong position. you may ave to take the turbo off and re-position the mount

Customer:

ok sounds easy enough..lol!! for any reason if that does not work is there anything else to check for??

Bamaman39 :

check the other clamps. make sure all is flush

Bamaman39 :

The -pipe is the most common

Customer:

ok..i knew there was a problem when my check engine light never came on after the instructions for the kit said it would!!

Customer:

thank u very much for the info..i hope its an easy fix..not time consumming

Bamaman39 :

it might still come on as the egr is deleted

Bamaman39 :

Its not that bad of a fix

Bamaman39 :

been doing them for a long time

Customer:

ur right but i dont wanna have to take all the intake pipes and other stuff back off!! im done with engine mods after this is fixed!!

Bamaman39 :

cool. Im 99 percent sure its the Y-pipe

Customer:

alright man well i appreciate all uve done on a sunday evening!! have a good one

Bamaman39 :

u to and good luck

Customer:

thanks

Bamaman39 and 3 other Ford Specialists are ready to help you

Related Ford Questions