How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 33460
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

99 windstar: lean..upper intake..fuel injector o rings

This answer was rated:

On a 99 windstar 3.8, I had lean both banks codes. I have replaced the lower and upper intake gakets, along with the fuel injector o rings. Before the repair the trims were about 23 both short and long. now the shorts are near zero, but the longs are upwards of 20. What do you think is the issue here? I can't find any other vacuum leaks. The mass air meter at idle is .72 volts and 3.43 grm
Hello and Welcome to Justanswer,

My name is XXXXX XXXXX I am here to try and assist your with your question.

The problem you are having is a very common problem and Ford has released a TSB that deals with it on the 3.8, you have done almost everything yo need to do except the valve cover . I have enclosed the TSB for you review, if you follow it, it should resolve this problem.

DOWNLOAD HERE
Customer: replied 5 years ago.
how can I tell if the valve cover has been changed already? It has no numbers on it, but it's grey
There really is no way to know without checking it with a new one. Its not likely been changed if your setting the P0171 and P0174.
Customer: replied 5 years ago.
If it were the valve cover, would removing the pcv hose and plugging it cause the trims to lower immediately? Would changing the valve cover provide immediate results?
No removing the PCV will not work and yes if its the valve cover you will resolve this problem, Its a very common issue on the 1999.
Customer: replied 5 years ago.
Ok. One last question. Based on the maf info above, do you think that it is operating alright?
Yes your MAF is fine.
Customer: replied 5 years ago.
If I increase the rpm to 1300 or so, all the trims are at zero. I called the ford dealer to order the valve cover, and they told me that it's not going to help me.
They are full of it, This is Fords repair for this problem. They are most likely trying to get you to bring it in. I have done at least a dozen of theses and it worked just fine as long as you follow the complete TSB. I can opt out if you are not happy with the correct answer but there are no other answers.
Ron and 3 other Ford Specialists are ready to help you
Customer: replied 5 years ago.
I have always been happy with your answers. I will give it a shot. They probably don't care much for me to begin with for specific reasons, and are messing with me. Thanks again.