How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pavlin Koev Your Own Question
Pavlin Koev
Category: Ford
Satisfied Customers: 3483
Type Your Ford Question Here...
Pavlin Koev is online now
A new question is answered every 9 seconds

97 f250: rebuilt..turbo,all bolts are tight, no exgaust leaks

Resolved Question:

97 f250 7.3 ps LOW boost maybe 5-6 at most up hill!! also have new edge programmer, starts nice runs smooth, 120k on rebuilt from ford, 220k on truck, have only had truck 1 month , also pulled intake hose, impeller spun freely, 1 tiny nick in 1 blade, no wet oil in the discharg side of turbo,all bolts are tight, no exgaust leaks that i can see or hear.
Submitted: 6 years ago.
Category: Ford
Expert:  Pavlin Koev replied 6 years ago.

Hi, check for Codes in engine computer. If engine performance is reduced due to computer detecting fault turbo will not work properly. Maybe you have done it all ready, but I just wont to be sure.



Customer: replied 6 years ago.
hi, the only code was the one that always pops up when you install a program. (p0603)and there was a code when i first hooked up the EDGE it was a back pressure code. i disconceted the back pressure senser on the front of the motor and ran it. No change. i cleared all codes about a week ago and have taken the truck on a trip and there are no codes now.
Expert:  Pavlin Koev replied 6 years ago.

Hi, back pressure sensor is treaded on top of a pipe that connects to exhaust, this pipe is plugged with carbon deposits and that is why no pressure there, best way to remove and replace.

Code P0603 is power loss to computer Keep alive memory, but if not coming back, it is just old code.

HERE read this, it is service bulletin from Ford if your injectors have not been serviced lately. this may be the problem.

Regards Pavlin

Customer: replied 6 years ago.
thanks , i'll look into it. if the pipe is cloged w/carbon could that cause low boost?
Expert:  Pavlin Koev replied 6 years ago.
Hi, no I have not see this affecting power.
Pavlin Koev and 3 other Ford Specialists are ready to help you