How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bamaman39 Your Own Question
Bamaman39
Bamaman39, Ford Technician
Category: Ford
Satisfied Customers: 2288
Experience:  10 years ford experience, Ford Senior Master Diesel And Gasoline Tech
17239397
Type Your Ford Question Here...
Bamaman39 is online now
A new question is answered every 9 seconds

1997 ford explorer: the injectors the fuel filter..leaks..maf sensor

This answer was rated:

my 1997 ford exploer has po171 po174 po301 po304 i have replaced the injectors the fuel filter checked for vaccum leaks did not find any checked the maf sensor readings with a multi meter it seams to be fine but still havent fixed the problem any ideas to fix it would help

Thank you for using just answer.

 

Is the truck running rough?

 

Customer: replied 7 years ago.
yes
99% of the time when you have lean codes for both sides and cylinder codes 1 and 4 you have a bad fuel pump.1 an 4 are the last to receive fuel and the lean codes show that the fuel trims are very low.You can do a fuel test if you want to but i really think you need a pump.

Edited by Bamaman39 on 11/28/2009 at 8:45 PM EST
Customer: replied 7 years ago.
is it just not supplying enough pressure or may it be clogged
The fuel pump should send 30 or more psi of fuel to the motor.When the pumps gets weak or goes bad it will send only around 8 to 10.If there was any clog it would have changed when you replace the fuel filter as this is the first thing to restrict fuel.
Bamaman39 and 4 other Ford Specialists are ready to help you

Related Ford Questions