How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask fix that car Your Own Question
fix that car
fix that car, Ford Mechanic
Category: Ford
Satisfied Customers: 493
Experience:  ten years working on ford cars and trucks
Type Your Ford Question Here...
fix that car is online now
A new question is answered every 9 seconds

ford ranger: rough idle and wont rev..Exhaust manifold..o2 sensor

Customer Question

I have a 93 2.3L ford ranger. It has rough idle and wont rev! Exhaust manifold glows red hot when trying to rev it up-( only about 1500- to 2000 rpms). Pulled front o2 sensor to let more exhaust out to eliminate cat. No diff. I back probed TPS signal wire and got .8- to 5 volts( seems ok) 4 wire maf-back probed signal wire and got 1.57- to 2.33- but engine wont rev---even cleaned maf. Only code is running code 412---makes sense!!! While test jumper in----( IT REVS UP )- and maf back prob is 1.57- to 3.99- ( seems ok ) dont have freq. or tach. to test maf, but seems ok. Took all of pcm conections off and found a lot of corrosion and thought ---BINGO---! Cleaned it very well---- and no good---- bummer!!! Iac selinoid is good. Seems like a timeing prob of some sort- maybe pcm? Could it be ignition module prob,? Checked lots of conections. PLEASE HELP!!! FRANK VITALE!!!
Submitted: 7 years ago.
Category: Ford
Customer: replied 7 years ago.
If the cat is plugged,--- why does it rev ok when the test jumper is in? If the cat is plugged---- The cat is plugged and wouldnt rev anytime--- CORRECT?
Expert:  fix that car replied 7 years ago.
you burn more fuel when the engine is under a load which results in more exaust. 1500-2000 rpms is not reving the engine very high. I just repaied a ford with the 3.0 that idled rough and had muffled backfiring yesterday red hot pipes = plugged cat or a restricion in the exaust sys.
Customer: replied 7 years ago.
It will only rev 1500-- to 2000 without the test jumper ---- with the test jumper , it revs the full rpm range!!!!!!!!!!!! And idles fine!!!
Expert:  fix that car replied 7 years ago.
I understand, if you you will dissconect the exaust pipe you will be able to drive the truck. it is normal to be able to rev with no load, but when it is in gear for it to not rev and run poorly, if the exaust is plugged. It will only take a few min. to dissconnect the pipe to make sure the problem is in the exaust sys.
Customer: replied 7 years ago.
But it doesnt rev with no load without the test jumper--- only 1500-to 2000 --------- and still no load WITH TEST JUMPER HAS FULL RPM RANGE ---- But i will pull it apart to prove MY point------ I have seen this prob all over Google- and they all replace cat- maf- tps- iac fuel pump etc.... with no results. will get back to you and if your right ----I will donate and PAY an additional 30dollars--------- STAND BY!!!!!!!!!!
Customer: replied 7 years ago.
Alright---------------- Just as I told you----- before I just cost myself exhaust bolts--- a hanger---- a gasket ---45min. drive time to get my compressor and inmpact and a half hr. labor-------------------------- N-O-------C-H-A-N-G-E.... If itwouldnt rev with no load - only to 1500- to- 2000 rpm--- but would rev full rpm range with no load with test jumper says cat is fine, and something is wrong through the computer and its system!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! NO CAT______STILL ___________NO REVS___1500- to 2000------------------- FRANK VITALE!!!!!!!!!
Customer: replied 7 years ago.