How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bamaman39 Your Own Question
Bamaman39
Bamaman39, Ford Technician
Category: Ford
Satisfied Customers: 2288
Experience:  10 years ford experience, Ford Senior Master Diesel And Gasoline Tech
17239397
Type Your Ford Question Here...
Bamaman39 is online now
A new question is answered every 9 seconds

2003 ford explorer running hot. just changed water pump,thermastat,

This answer was rated:

2003 ford explorer running hot. just changed water pump,thermastat, thermastat housing,

Thank you for using just answer.

 

Does it get hot while at idle or driving?

Are you getting pressure on the top radiator hose?

Do you have a manual or electric fan?

Customer: replied 7 years ago.

after changing the priously listed part it was running fine while driving but over heated while stuck in traffic. When we turned around to head back it would go up 3/4 way hot then go back down to half way. Turning the heater on makes the engine cool off allowing us to make it back.

 

By pressure im assuming you mean hard. Not really that hard i can squeze it preety easy.

 

Manual fan

 

4.0 v6- i didnt state that earlier

Have you cracked the cap to see if any air came out?There will be some but not alot

Also how long ago was the repair before it started acting up?

Customer: replied 7 years ago.

Changed part yesterday.

Cracked the cap and there was lots of air. It was hot when the cap was craked. Water bubbling and coming out.

Ok there are two things.One there was alot of air still in the system,or the thermostat was installed wrong.Since you have released the air i would take it for a drive or let it sit and let me know what happens.
Customer: replied 7 years ago.
The air was let out of the system and ran once before i got on the road so i dont think that is it. By themastat installed wrong, please explain how it could be wrong. I am sure it only goes one way. I place the thrmastat o ring in first then the thremastat. Is that correct or should the stat go in then the o ring?

The thermostat should be put in first then the oring on top of it

Also make sure that the front of the radiator is not being clogged up by grass and dirt

When you put the oring in the housing and if it does the same thing and the radiator is clean then i would look at the fan clutch.If a fan clutch doesnt operate correctly it will make it run hot and also make the needle go from hot to warm.This is the only other option other than a new radiator.
Bamaman39 and 3 other Ford Specialists are ready to help you
Customer: replied 7 years ago.

Ok car has been idling in the driveway for about 20 min with no problem. Holding steady just a tick below half way. Is it safe to assume it is ok? Im visiting family in new orleans and have aXXXXXback to shreveport with a six week old.

I would think so.If you want to drive it around for 20 mins and see if it goes up any.Then you will know for sure.I think its fixed but i know whats its like to have a peace at mind