How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask powerstroker24 Your Own Question
powerstroker24, Master Diesel Technician
Category: Ford
Satisfied Customers: 255
Experience:  11+ yrs diesel exp. Ford Master Diesel certified. ASE L2 Advanced Diesel Diagnosis cert., ASE T2,T6
Type Your Ford Question Here...
powerstroker24 is online now
A new question is answered every 9 seconds

F350 Super Duty: the alternator..instrument either..fuses

This answer was rated:

My 02 F350 Super Duty had an alternator issue earlier this week, I posted the problem here and received an excellent reply. After changing out the alternator, I now find that I my entire instrument panel is dead, my radio is out and my electric windows do not work either! I changed out two dead fuses in the fusebox however it did not fix the problem. I did disconnect the battery before I worked on the alternator and charged it to start the truck , the alternatior was since tested and is functioning properly. The trucks runs ok however I have no power to most of the dashboard with the exception of the lights,wipers and the cigarette lighters. Please advise!
Thanks for your question and I believe I worked with you before. Since replacing the fuses have we insured they did not blow again? Also which fuses were blown?
Customer: replied 7 years ago.

Thanks for the prompt reply! The truck lost all electrical power on the road again yesterday after I had changed out the alternator> I had it towed to the wreckers garage and he found that the new alternator was not charging then after looking at the fuse panel realized that there were two fuses out, one fuse fixed the alternator problem and I do not know what the other fuse did! He gave up on me after about an hour and a half however I do not feel he was very qualified. I drove the truck home 8 miles and it had no problem starting again this morning.

I checked all the fuses this morning and they all seem to be intact!

Have we insured good connections at both batteries and the alternator? Have we checked ALL fuses?
Customer: replied 7 years ago.

The fuses are all intact, and The terminals are free from corrosion and tight to the poles as I said the truck starts/runs, wipers work at full, speed lights work just the panel,radio and windows are out

It sounds as if we may have a issue with the accessory delay relay or fuse 2.42. The relay is the bottom row of relays in the middle(try swapping it with another). The fuse

is a 15 amp mini on the bottom row(below the relay) and is the 7th from the right(or the ninth from the left. Please reference your owners manual if having trouble locating these.

Customer: replied 7 years ago.

I switched the Relay out with the one to it's right and had no success then I checked the fuse below and it is also good! Thank you for all your help. Might you have any more suggestions?

Do the dome lamps and courtesy lamps work?
Customer: replied 7 years ago.

yes all inside lamps work! Could it be a circuit breaker that controls the power windows 30 Amp 601?

Customer: replied 7 years ago.
I was wrong I just checked the domelights/courtesey lights are out also!
Okay that tells me it may be a battery saver relay issue. Insure 2.41 and 2.35 are good again. The battery saver relay is internal to the instrument cluster. We may need to disconnect both batteries for a hour or so and see if this will correct this issue. If not then I could disconnect the instrument cluster(remove it) and reinstall it.
powerstroker24 and 2 other Ford Specialists are ready to help you
Customer: replied 7 years ago.

Thanks I will try disconnecting the battery - only one battery in my F350!

Fuse #35 is the instrument cluster- correct?

Customer: replied 7 years ago.

I do appreciate all your time and I will pay your for your efforts however I need to fix this perplexing issue before our next snow storm on Saturday .How do I locate the battery saver relay?

It is internal to the instrument cluster and cannot be serviced. Try disconnecting the batteries and if that doesnt work disconnect the instrument cluster as I stated in my previous message. Hopefully this will get her.
Customer: replied 7 years ago.

I just reconnected the battery and everything is working again!

I am so very grateful to you for your assistance and will give you 100% feedback and write a positive review of your professionalism.

It's very comforting to know that there are people out there like you who know what they are doing and save us thousands of dollars in repair fees.

Many thanks -CustomerSmile

Your very welcome and I am glad I could help out.