How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ray M. Your Own Question
Ray M.
Ray M., Ford Master Tech
Category: Ford
Satisfied Customers: 3011
Experience:  30+ years in trade, Ford Master Tech, Journeyman Automotive Tech
Type Your Ford Question Here...
Ray M. is online now
A new question is answered every 9 seconds

2008 f-250: wont start..hood..the instrument panel..brake system

This answer was rated:

my 2008 f-250 ford superduty won't start. when the key is turned all the lights on the instrument panel blink and noices come from under the hood but nothing ever happens. the instrument panel also blinks check the brake system. i was told that it could be a ABS sensor, but i was also told that it could be the anti theft system locking my engine out. i have talked to 6 dealerships in my area and none of them know what could be wrong. has anyone ever heard of this? and if so what could it be?

What have you tried so far?

Have you tried boosting it?

Customer: replied 7 years ago.
well by boosting what do you mean? (sorry i'm female don't always know things) we recently bought a SCT programmer and delete pipe for it for better fuel milage but i have not received it yet. i ordered that before it started doing all of this. it started on the 31st of december when i was at the eye doctor. i left it running came out 1 hour later and it had died. it started right up and left parking lot. then on way home on interstate it jerked really hard like the brakes were locking up. so when i got to the house i pulled under the carport and turned the truck off. it was then that i realized the i forgot something. so i went to turn it back on and it wouldn't start. i told my husband about the situation and he unhooked the batteries for about 20 min. just yesterday my husband was wanting to get it ready for when the delete pipe gets here so he took it around back to our garage and pulled the pipes off. when he was done he backed it up to clean up the mess and when he went to start it back up it didn't work. he unhooked the batteries again, and it still didn't work. we had to push it in the garage to close the door. over the course of all this we have been calling dealerships and no one knows what it could be. this truck only has 42,000 miles but then again no warranty (don't really want to pay labor if it can be fixed by us)all the times that you try to start it, all the lights on the instrument panel flash and it flashes check the brake system. but the headlights and the radio come on when you try to start it. (also yesterday we hooked up a diablo sport chip that we have had for it to see if it would override the factory program and it said the it would not accept it and the it was not for that truck, but we have had it on there before but took it off because it wouldn't do the regeneration.) what do you think it could be?
It sounds to me like you have dead batteries,by boosting I mean hook jumper cables up to one of the batteries to see if it will turn over and start.
Customer: replied 7 years ago.
we have tried hooking my gmc up to it with jumper cables and it didn't even phase it. i thought about the batteries since they are probably about 2 years old and never been changed but i didn't know. other than that is there anything else that i might try if this doesn't work? or have you never heard of this problem
It sure sounds like a battery or battery connection problem,check the ppositive cable on both batteries,make sure that the nuts holding the power wires on are tight and both battery cables are tight.Do you have a battery charger to hook up and charge the batteries over nite? They may be low enough and then even a jump with another battery is not enough to crank and start it.
Customer: replied 7 years ago.
alright thanks so much for your help. i will definatly try this. if it doesn't work then i will probably be back with another question. thanks again.
I will be here.Let me know what you find?
Customer: replied 7 years ago.
how do i accept your answer?
I believe the accept button is in the left upper corner of the box,it is a green button.
Ray M. and 3 other Ford Specialists are ready to help you
Customer: replied 7 years ago.
alright we bought 2 new batteries and it starts but had to get under it and hit the starter. there must be a sensor or electrical problem between the ignition and the starter not letting it respond. thanks for all your help.

The low voltage has probably damaged the contacts in the solenoid on the starter,that is why when you hit it ,it worked,if it happens again you may have to replace the starter.

I would be very interested to know how the programmer and delete kit affect mileage.Could you PM me here to let me know?

Customer: replied 7 years ago.
sure be in touch thanks
Okay,Thank you

Related Ford Questions