How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 33019
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

my speedometer and odometer quit working on my 94 f150 ...

Customer Question

my speedometer and odometer quit working on my 94 f150 what should i check on to fix it?
Submitted: 8 years ago.
Category: Ford
Expert:  Ron replied 8 years ago.


Thank you for asking your question on Just Answer.


At the back of the cluster check the Light Green/Yellow (LG/Y) wire from fuse 8, terminal 1 to verify it's hot at all times. Check the White/Purple (W/P) at terminal 3 from fuse 18 and verify it's hot when the key is in the run position.

Check to see if the Antilock Brake System (ABS) light is on. If the ABS light is on, start with that first. Pull codes to see if there is a Vehicle Speed Sensor (VSS) code.

If OK, at the 12-terminal connector at the back of the instrument cluster, check for a good AC voltage signal between the RD/PK pin 4 and LG/BK pin 5 wires. The higher the speed, the higher the voltage.

If the AC voltage signal increases with speed as it should, verify good power feeds on pin 1 LG/Y and pin 3 WH/VT and good ground on pin 2 PK/OG.

If all is OK, but there is no speedometer operation, replace the instrument cluster.

Customer: replied 8 years ago.
Is it possible that the speedometer cable is loose? If so where do I find that? And could it possible be the gear?
Expert:  Ron replied 8 years ago.
Start at the trans tail shaft where it hooks on and remove it from the housning and spin the gear with you hand and watch the speedo for movement.
Customer: replied 8 years ago.
What does the cable look like? And where exactly can   I find it? Thanks
Expert:  Ron replied 8 years ago.
It should come out of the left side of the trans mission tail shaft housing. It will look like a gray cable.
Customer: replied 8 years ago.
Well i looked around a while but then i got to thinking that maybe it was digital and so i pulled out the instrument panel and sure enough it is what would be the problem with that? I dont think it can be a fuse or any thing like that because it worked off and on for awhile than it would just bounce all over the place and now it doesnt move at all. any suggestions?
Expert:  Ron replied 8 years ago.
I would start with running the test I sent you in my first reply as its eaither a connection or the speedo its self. Running the test I sent you lead you to it.