How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 35061
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

1995 Ford F150: 4X4..speedometer..quit working..the speed sensor

This answer was rated:

1995 Ford F150 5.8 L 4X4 automatic, the speedometer and odemeter quit working and the transmission shifts late and very harsh, my son took it to his high school automotive class and they plugged a scanner to it and it gave a 452 code, this truck has the speed sensor on the rear differential, it had 1.845 ohms but tried a new one from the parts house, it ohmed at 1.065, still no speedo or odometer, did not drive, ohmed wires at the fire wall plug under the hood 1.838 old sensor & 1.066 new sensor, what is my next step or did I miss something
The most common problem with the 1995 F-150 speedometer not working and the trans shifting hard is caused by a bad PSOM (programmable speedometer/ odometer modual) The PSOM converts the analog VSS signal into a digital signel and sends it on to the PCM for a VSS input. I would suspect your PSOM (speedometer assembly)is bad. Im sending you the test to decide if this is the case.graphic
Ron and 5 other Ford Specialists are ready to help you
This also set the code 0452.
Customer: replied 9 years ago.
Ron I drove this a few blocks with the sensor disconnect and it seemed to shift ok, just come out of warm shop, my son took it for a drive, had been sitting outside about 10 degrees and he said he sifted the same way as before harsh and the light was blinking in the shift lever, do I have another problem?
No its the same problem as the trans wont shift right with loss of PSOM. It likely you will need to repair your PSOM to be 100 percent correct.