How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Lincoln
Satisfied Customers: 21609
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Lincoln Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Have 99 navigator speedo works cold then drops to 0 trans

Customer Question

have 99 navigator speedo works cold for seconds then drops to 0 trans shifts hard
Submitted: 1 year ago.
Category: Lincoln
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to Justanswer!

It does sound as if you're losing output speed sensor signal. The output speed sensor signal is used both for the speedometer and for transmission shifting functions. The loss of speedometer could be an instrument cluster issue but if you have shift problems at the same time then most likely you're losing output speed sensor signal. If the sensor was replaced with a good part then then issue could be in the powertrain control module but is most likely a wiring or connection issue.

Do you know what fault codes are setting?