How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask A. Penland Your Own Question
A. Penland
A. Penland, Ford Senior Master Technician, ASE
Category: Lincoln
Satisfied Customers: 6212
Experience:  ASE Master Certified. ASE Gasoline Engine Performance Certified,Ford Senior Master Technician
14865528
Type Your Lincoln Question Here...
A. Penland is online now
A new question is answered every 9 seconds

Moose, 2013 Navigator...front a/c does not blow, in any

Customer Question

Moose, 2013 Navigator...front a/c does not blow, in any mode...heat, ac, defrost...rear ac blows and gets cool...any thoughts
Submitted: 1 year ago.
Category: Lincoln
Customer: replied 1 year ago.
2012 not 2013
Expert:  A. Penland replied 1 year ago.
Hello and thanks for using JustAnswer.I will try my best to help you with your question.
You are getting no air flow through any of the front vents, like the fan motor is not working?
Customer: replied 1 year ago.
correct..no air flow from the front at all...
Customer: replied 1 year ago.
The rear system is blowing cold air but it's like the front fan is not working...if I open the windows, I can hear what sounds like the fan trying to run, but it never blows in the front
Expert:  A. Penland replied 1 year ago.
It could be the blower motor, blower motor fuse or the blower speed controller.
First, check for power to the blower motor under the dash on the passenger side. You should have power to the blower motor on the YELLOW/GREEN striped wire with the key on and the AC turned on.
Please check this first and let me know what you find.

Related Lincoln Questions