How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Lincoln
Satisfied Customers: 21604
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Lincoln Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

Lincoln town car: I have a 95 Lincoln town car and have been

Customer Question

I have a 95 Lincoln town car and have been experiencing my car at random times will rev high while i am driving but i will get no acceleration. this will happen at random but is happening more frequent now. happens more so at higher speeds from 40-60 mph. rpms will go up but like i said no acceleration then will drop back down and will drive like normal again. sometimes car will jerk and have a hesitation. theres no check engine light on. the car has just under 60k on it.
Submitted: 1 year ago.
Category: Lincoln
Expert:  sprinkles08 replied 1 year ago.
Hello and welcome to Justanswer!
If the RPM's jump up and the car quits pulling then the issue is in the transmission. It may be a clutch slipping or it could be disengaging due to a line pressure issue. If the fluid level is low, the sump filter is damaged and allowing the pump to suck air, or if the filter is restricted with debris then it will cause a drop in line pressure.
Has the fluid level been checked?
Have you checked for fault codes?
Customer: replied 1 year ago.
The fluid isn't low checked that. And for fault codes not that ive seen. Theres no cel on. I brought it into a shop over a month ago and they couldn't get it to replicate. Now though its more frequent and happens every day it seems. the fluid is red but I believe the last time the fluid was changed was back in 2007. Could it be that the friction properties have faded away causing the clutch to slip or lose pressure?
Expert:  sprinkles08 replied 1 year ago.
It shouldn't be a fluid degradation issue but the filter may be restricted with debris. Has the problem gotten worse gradually or is it worse when hot?
Customer: replied 1 year ago.
Its been gradually but does seem to happen after the car gets to operating temperature
Expert:  sprinkles08 replied 1 year ago.
That would make it more likely to be a restricted filter. The longer the engine runs the more debris will be pulled into the filter which will drop line pressure. Based on that and the fact it has been so long since the fluid has been changed I would recommend dropping the pan, inspecting for excessive debris that would indicate a deeper failure, replace the filter an re evaluate it.

Related Lincoln Questions