How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Russell H. Your Own Question

Russell H.
Russell H., Service Tech
Category: Exercise Equipment
Satisfied Customers: 9306
Experience:  8+ years of professional experience
Type Your Exercise Equipment Question Here...
Russell H. is online now
A new question is answered every 9 seconds

I have a C900pro ,I bought it a few years ago. I put it up

Customer Question

I have a C900pro ,I bought it a few years ago. I put it up last month . It will not do anything. what can i do ?
Submitted: 5 months ago.
Category: Exercise Equipment
Expert:  Russell H. replied 5 months ago.
Hi, thank you for contacting My name is Russell. I will do my best to provide the right answer to your question. It is often a mistake to buy an appliance and then not put it into use in the first year of owning it. This allows the basic warranty to expire, without being sure whether you have bought a defective device, whose warranty coverage would otherwise see to its being repaired for free. As things are, we need to assess how badly it is defective: 1. does it have lights on it? or anything showing on the console? if not, check the power cord, the breaker switch if it has one, and the power switch for certain. Also be sure the outlet you plugged it into is still good, by plugging another device into it into its place. 2. if it shows anything on the console, is the display normal, and does it react to button presses or respond to controls? if not, the control console may have a problem managing and directing the machine's functions. 3. if the display is behaving normally, but the belt fails to move, be sure you have the safety key in place, at least. Let me know more about the problem, and I will instruct you further, as appropriate. Thanks.
Customer: replied 5 months ago.
It shows nothing on the console, like no power is on. I have the motor hood off , I see a red light on
Expert:  Russell H. replied 5 months ago.
Do you see any other lights? if so, what color, and are any flashing? If it acts as if no power is On, it is most likely in trouble because of a shorted component, which could prevent the device from starting up.
Customer: replied 5 months ago.
No other light
Expert:  Russell H. replied 5 months ago.
If there is no other light, it is either disabled because of a bad power connection - make sure to check that - or because the breaker needs a reset - or, because of an internally shorted component.Obviously, if it comes down to that last, then if you disconnect one component and it turns On (even if it doesn't function much or fully because of the removed component) it will locate the shorted component.