How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Neil Your Own Question

Neil
Neil, Technician
Category: Exercise Equipment
Satisfied Customers: 3735
Experience:  NZCE Electronics and Computing
15873252
Type Your Exercise Equipment Question Here...
Neil is online now
A new question is answered every 9 seconds

My preform 625 PT belt will not run. Console works/lights

Customer Question

my preform 625 PT belt will not run. Console works/lights up, but when I hit speed the belt does not move. Incline works, etc. all work, just the belt does not run. I took hood off and when I hit "speed" for the belt, one of the lights on the pressed electronic board (with hood off) flickers. Any ideas, etc. on what I can check/do?
Submitted: 11 months ago.
Category: Exercise Equipment
Expert:  Neil replied 11 months ago.

Hi

Does the belt give a little shudder? Or no movement at all?

Customer: replied 11 months ago.
no movement at all
Customer: replied 11 months ago.
hello?
Expert:  Neil replied 11 months ago.

Sorry but I had stepped away...

You will need to check the connections to that motor control board under the console...

Test the motor using a battery, you can use the battery from a cordless drill, the motor may only move slowly but it should move, if not then the motor has failed. If it does move then we need to check the motor control board.