How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Pete Your Own Question

Pete
Pete, Electronic Engineer
Category: Consumer Electronics
Satisfied Customers: 16345
Experience:  Over 16 years of experience installing and repairing electronics.
30970729
Type Your Consumer Electronics Question Here...
Pete is online now
A new question is answered every 9 seconds

On Nikon D500 - raw ISO button does not work after a frame

Customer Question

On Nikon D500 - raw ISO button does not work after a frame has been shot. Must turn cam off & back on to change ISO manually
JA: What's the make/model of your device? How old is it?
Customer: nikon d500 4 months
JA: How long has this been going on? What troubleshooting have you tried?
Customer: Tried auto ISI on & off - makes no difference
JA: Anything else you want the electronics expert to know before I connect you?
Customer: no
Submitted: 13 days ago.
Category: Consumer Electronics
Expert:  Pete replied 13 days ago.

Hi, I'm Pete. Welcome to JustAnswer! I'm reviewing your question now, and will post back with your reply ASAP.

Expert:  Pete replied 13 days ago.

Are you using auto-ISO?

If not, and you are still unable to change the ISO after shooting a frame, then try updating the firmware on the camera:

http://downloadcenter.nikonimglib.com/en/download/fw/205.html

--------------------
Your satisfaction is my priority;
Kindly take a moment to rate my service 5 stars and press submit at the top of your question page so I am rewarded for my time; tips appreciated :)
You can always reply back at any time if you need any further assistance at all.
Pete.
--------------------

Customer: replied 12 days ago.
Manual ISO - and the Firmware is up to date. Actually the problem exists on auto as well - although I am not sure if it's possible to override auto ISO Main problem is in manual ISO No criticism intended - but the question remains unresolved.
Customer: replied 12 days ago.
Well, I responded that the question remains. Camera FW is up to date. The web site does not let me know it the response was sent.
Expert:  Pete replied 12 days ago.

I got your reply, thanks.
Can you try a factory reset of the camera and let me know if that works?

Expert:  Pete replied 10 days ago.

Hi, just checking in on your question. If the issue is resolved or you do not need anymore help, please rate our session as 4 stars or more and press submit so I am credited for my time, otherwise please reply back so we can continue with the issue.

Customer: replied 10 days ago.
The issue remains. I suggest U spend no more time. Nikon support does not have the answer. Appears this may be a defect.
Expert:  Pete replied 10 days ago.

Ok, if I can be of any further assistance, just let me know.

Best,

Pete.

Expert:  Pete replied 6 days ago.

Is there anything else I can help you with?

--------------------

Your satisfaction is my priority;

Kindly take a moment to rate my service 5 stars and press submit at the top of your question page so I am rewarded for my time; tips appreciated :)

You can always reply back at any time if you need any further assistance at all.

Pete.

--------------------