How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Pete Your Own Question

Pete, Electronic Engineer
Category: Consumer Electronics
Satisfied Customers: 15464
Experience:  Over 16 years of experience installing and repairing electronics.
Type Your Consumer Electronics Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a BenQ Mx720 project. I replaced the lamp and chip

Customer Question

I have a BenQ Mx720 project. I replaced the lamp and chip today and when I turned it on, it started but no image appear, only a square of light.
I tried to put back the old chip, same issue. Then I put back the old lamp and it still the same.
I have been very careful to plug everything at the right place but I might have miss something.
Any ideas what it could be ?
I really look forward to hear from you.
Thank you
Submitted: 29 days ago.
Category: Consumer Electronics
Expert:  Pete replied 29 days ago.

Hi, I'm Pete. Welcome to JustAnswer! I'm reviewing your question now, and will post back with your reply ASAP.

Expert:  Pete replied 29 days ago.

Ben, you might need to adjust the brightness up or down.

Also verify that the appropriate input source is selected and the cables are connected securely.

Let me know if that helps?

Customer: replied 29 days ago.
Hi Pete,
This isn't the issue. Before I tried to change the lamp and the chip, when I turned on my projector, even when it wasn't connected, I was seeing the benq home screen and was able to access the menu with the remote.
At the moment I just have a blank screen, it is really only the light projecting, no image what so ever.
I thought it could have been because the chip I bought wasn't the right one but even after reinstalling the old chip the problem is the same.
FYI : The projector is 5yo.
The lamp was a bit dim and the chip was loosing mirrors but it was functioning.
Expert:  Pete replied 28 days ago.

Ok, if you aren't even getting the BenQ splash screen then no image is being processed at all by the DLP chip.

Could any tools have come into contact with the DLP chip, or could any internal connections or components have been damaged in any way during the new lamp installation?

Related Consumer Electronics Questions