How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask John Your Own Question

John
John, Engineer and electronic enthusiast for more than 12 years.
Category: Consumer Electronics
Satisfied Customers: 224
Experience:  I am here to help you!
23822421
Type Your Consumer Electronics Question Here...
John is online now
A new question is answered every 9 seconds

My verifone ruby got confused when we tried to prepay the

Customer Question

My verifone ruby got confused when we tried to prepay the pump and they tried to pump at the same time, #1. It now says In USE, But after rebooting and reinitializing, the flashing handle is gone,on it but hte other pumps all say Wrong State? Is this something you deal with?
JA: What's the make/model of your device? How old is it?
Customer: OLD.. Where would I get that, I just know it is a RUBY model
JA: How long has this been going on? What troubleshooting have you tried?
Customer: An hour maybe. I have tried unplugging the PAM fuel box and rebooting the cash register. I have tried to clear anything on hold. ReInitialized fuel
JA: Anything else you want the electronics expert to know before I connect you?
Customer: not that i can think of, but how does this work?
Submitted: 2 months ago.
Category: Consumer Electronics
Expert:  Russell H. replied 2 months ago.

Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.

So the Verifone Ruby is OK now, I take it. But your pumps read an error on them?

If the problem is with the pumps (or something attached to them), then what type of pump are they?

If you turn Off the Verifone Ruby, what do the pumps then say while it is Off ?

Customer: replied 2 months ago.
They are Gilbarco pumps. The register works, but if u try to aurhorize #1 says IN USE, the other 3 say WRONG STATE
Expert:  Russell H. replied 2 months ago.

Turning Off the Verifone, then checking the Gilbarco pumps, results in what, on the pumps?

Customer: replied 2 months ago.
The pumps stay ON meaning the lights are on, but they will not authorize
Expert:  Russell H. replied 2 months ago.

Of course they won't authorize, when the Verifone is Off.

What I mean is, does their error message indication go away?

I suspect it is... let me know, please.

(I regret that I am not able to offer Live Phone Call service at this time; However, your request is still open to other Experts in this category, and one of them may pick up on it at any time.)

Customer: replied 2 months ago.
The error message is on the verifone... When I turn it off, it is off.... When I turn back on, the pumps will not authorize... If I am understanding ur quesyion
Expert:  Russell H. replied 2 months ago.

So there is no WRONG STATE nor IN USE message on the pumps at any time, then?

If 'no', then the errors are on the Verifone, correct?

If so, then how did you reset it? (- the Verifone.)

Customer: replied 2 months ago.
The PUMPS are fine, the register is fine, but when I want to authorize the pumps, 1 says. IN USE the other 3 say E#409 WRONG STATE ON THE. Verifone. Not sure how else to describe it...
Expert:  Russell H. replied 2 months ago.

How did you reset the Verifone?

Customer: replied 2 months ago.
First, I unplugged it to reboot, which is when I also unplugged the PAM box. Then I was in manager, or fuel manager and there was a thing to "reboot". I did that also. THAT. Stopped the #1 from flashing, but still will not authorize
Expert:  Russell H. replied 2 months ago.

OK. I think that since 'wrong state' is indicated, the problem is, that the Verifone still thinks it has a transaction going on.

Was that transaction actually paid for? can you abandon it now? or would you rather not abandon payment through the Verifone system?

If you can abandon it, the Verifone system obviously needs the bungled transaction cleared from it.

And a power-Off has evidently not cleared it.

Customer: replied 2 months ago.
I do not believe the transaction was completed because it started flashing when she was ringing it up, but there is no sale showing on register. I went to CLEAR PUMPS ON HOLD under fuel manager, and tried that. I don't know what u mean by "abandon sale". I am more than willing to abandon it!!!
Expert:  Russell H. replied 2 months ago.

Good.

Try a fuel init, in Fuel Manager:

11. Initialize Fuel > Fuel Initialization > Full Initialization.

Customer: replied 2 months ago.
Ok. Trying that again
Expert:  Russell H. replied 2 months ago.

OK. If that doesn't clear it up, then:

Check whether the pump's status (#1, I think, that sometimes says IN USE), is RESERVED.

Pump #

View

View

View

is how to do that.

Customer: replied 2 months ago.
It seemed fast for full initialized went thru all pumps, but is still saying *initialize fuel * on screen.
That went off. Looking for the clear reserved pumps. Can't find. When I do 1 view view view. It says pump offline???
Expert:  Russell H. replied 2 months ago.

Then the pump is Offline.

Wait 5 more minutes... it may take a little while.

Then after that, do another CLEAR PUMPS ON HOLD, if it still stays in PUMP OFFLINE status.

Customer: replied 2 months ago.
Ok. Will do and let u know
Expert:  Russell H. replied 2 months ago.

OK.

Customer: replied 2 months ago.
Still saying offline...
Expert:  Russell H. replied 2 months ago.

Perhaps the whole system needs restarting.

Check the fuel status connection to the Verifone. (If the Verifone is not On, turn it On at this point, to allow the whole system to communicate. ?)

Customer: replied 2 months ago.
Fuel status connection to verifone??? I checked the com port #6 that connects to the fuel box? Or is there something else?
Expert:  Russell H. replied 2 months ago.

Yes, that cable.

Are the pumps showing anything now? on the pumps themselves, I mean, not on the Verifone?

Customer: replied 2 months ago.
The pumps have electricity to them, I tried to send down a price change, it did not work... Like they are not communicating
Expert:  Russell H. replied 2 months ago.

I fear that you may have to contact Verifone's help desk about this problem, then.

I have run out of advice for the situation, I'm sorry to have to say.

I have Opted Out of this case, opening it to other Experts (should any other Expert here have more to suggest.)

Customer: replied 2 months ago.
Ok. Thank u for helping