How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask John Your Own Question

John, Engineer and electronic enthusiast for more than 12 years.
Category: Consumer Electronics
Satisfied Customers: 221
Experience:  I am here to help you!
Type Your Consumer Electronics Question Here...
John is online now
A new question is answered every 9 seconds

We had a power hit for a second due to a storm and my remote

Customer Question

We had a power hit for a second due to a storm and my remote just says waiting for network. I have tried the batteries and the code numbers, and still nothing. It did say leaving network one time, but still back to "waiting for network." It is model C4-SR250B-Z-B
Submitted: 2 months ago.
Category: Consumer Electronics
Customer: replied 2 months ago.
Just checking on the progress with this request and to see if there is a quicker way to get a remedy. THANKS
Customer: replied 2 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 2 months ago.
a live phone call would be great - we were just checking on progress. if there is no answer yet, just let us know. THANKS MUCH!
Expert:  Russell H. replied 2 months ago.

Hi, thank you for contacting My name is Russell. I will do my best to provide the right answer to your question.

Try turning Off both the remote, and the Control4 box, for at least 10 minutes. Also turn Off your local WiFi router. (Note: if the remote has no power switch, then just remove its batteries.)

(I am guessing you have a Control4 remote.)

After that 10 minutes, turn On the WiFi router, only, again.

Wait 2 minutes or longer.

Then turn On the Control4 box.

Wait 2 minutes or longer.

Then try turning On the remote, and seeing whether you can get it working in the normal fashion.

(I regret that I am not able to offer Live Phone Call service at this time; However, your request is still open to other Experts in this category, and one of them may pick up on it at any time.)

Customer: replied 2 months ago.
This did not work. Do you havevany otger soluriom as our problem has not yet been resolved
Customer: replied 2 months ago.
Any other solution
Customer: replied 2 months ago.
Sorry typo. Do you have another solution as problem as not been resolved. Your fix didnt work.
Expert:  Russell H. replied 2 months ago.

OK, understood.

I'm sorry to say that if the problem is the same, then the Control4 box may have been damaged by the power failure.

But another Expert might know of more to suggest, so I have Opted Out, opening the case to other Experts.

Customer: replied 2 months ago.
Since we were unable to get this issue resolved, we had to call the company and arrange for a technician to come out to troubleshoot. He said it was not any power issues, just settings. Since we were unable to get a working answer, we assume we will not be charged for this service. Please confirm.

Related Consumer Electronics Questions