How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Pete Your Own Question

Pete, Electronic Engineer
Category: Consumer Electronics
Satisfied Customers: 15426
Experience:  Over 16 years of experience installing and repairing electronics.
Type Your Consumer Electronics Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a lowerance hds 10 gen 2 system. the puck was

Customer Question

I have a lowerance hds 10 gen 2 system. the puck was professionally mounted on my 39 ft boat 14 months ago. it is a in hull transducer. i do not use the sonar function very often. last week i attempted to use the sonar function. in one screen it says stopped and in the other screen it says no source. with this information can you tell me if it is the main unit or the transducer. if you think it is the transducer what pins should i ohm out and what is a good reading. P.S. the boat is 325 miles from me. Leonard
Submitted: 3 months ago.
Category: Consumer Electronics
Customer: replied 3 months ago.
Expert:  Pete replied 3 months ago.

Hi Leonard,

You will need to check for a loose connection first.

Remove and re-attach each connetion to ensue it is securely connected.

If all cables are securely attached, then the fault is likely with the transducer - this can be confirmed by attaching the main unit to another transducer.

Kindly rate my service 5 stars at the top of your question page if my answer worked so I am rewarded for my time; otherwise please reply back if you need further assistance or clarification.


Expert:  Michael replied 3 months ago.

Hi Leonard, did you try Pete's suggestion?

I have further advice for you if you need.

Thank you

Tech Michael

Customer: replied 3 months ago.
Very poor response. That response is a gerneric response. Would fit almost any sympton. I doubt that you you even know what the different scenes on this unit are. I gave you very Pacific information and received nothing of value. Would normal say nice try but it was not.
Expert:  Pete replied 3 months ago.

Hi Leonard,

Apologies if you feel my response was basic, however we need to start there first and ensure there are no connection issues before proceeding!

Can you confirm you have carried out all of the checks I suggested?

Related Consumer Electronics Questions