How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Russell H. Your Own Question

Russell H.
Russell H., Service Tech
Category: Consumer Electronics
Satisfied Customers: 9772
Experience:  8+ years of professional experience
13568747
Type Your Consumer Electronics Question Here...
Russell H. is online now
A new question is answered every 9 seconds

I have thePLMRBS9 marine unit. It's not working. The Red

Customer Question

I have thePLMRBS9 marine unit. It's not working. The Red PROTECT LED INDICATOR is on but not the green led power light. What's wrong???
Submitted: 8 months ago.
Category: Consumer Electronics
Expert:  Russell H. replied 8 months ago.
Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question. Generally, when a Protect function goes into action, something on the output has been short-circuited. In this case, I advise turning Off the device, and disconnecting all connectors to the PLMRBS9 device, except the power. Then wait about 5 minutes or longer, and then power it On again, or try to.If the Protect persists and the device still does not power On, then disconnect the power and check whether the power isA. reversed, orB. deficient or excessive in voltage level, for the tolerances of this unit's specifications. Let me know how it goes, please. I will advise you further as appropriate. (And if this answers your question fully, please rate my answer. Thanks.)
Customer: replied 8 months ago.
Attempting now.
Customer: replied 8 months ago.
Tried both and no luck. Red light remains on but not the green power button.
Expert:  Russell H. replied 8 months ago.
Then the power supplied to it may be defective... or else, the short-circuit that Protect mode usually signifies, is internal, and the device will have to be repaired. Incidentally: What maker or manufacturer is the device in question, please?