How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Electronic Engineer
Category: Consumer Electronics
Satisfied Customers: 16890
Experience:  Over 16 years of experience installing and repairing electronics.
30970729
Type Your Consumer Electronics Question Here...
Pete is online now
A new question is answered every 9 seconds

My garmin 500 edge yesterday was not showing any percentage

Customer Question

My garmin 500 edge yesterday was not showing any percentage grade on climbs or descents. It was reading 0 grade. The real interesting part is it showed I had a 39,000 elevation gain on a 25 mile ride and it was a level reading all across the whole ride. When I corrected the elevation online on Strava, my ride was 1,400 in gain. Is my barometer fried? Weather yesterday was sunny, 31F, 21F chill factor with 13mph wind if that matters.
Submitted: 1 year ago.
Category: Consumer Electronics
Expert:  Pete replied 1 year ago.

Hi there,

It is more likely that the holes for the barometric sensor are blocked, so it does not know that the altitude is changing. this is a common cause of zero percentage grade.

Check and clean the barometric sensor holes on your Edge 500 then test it again.