How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Electric Vehicles
Satisfied Customers: 4679
Experience:  Owner at DJ Wilson
65405794
Type Your Electric Vehicles Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I installed new batteries & I crossed the last connections

Customer Question

I installed new batteries & I crossed the last connections wrong & they sparked for about 3 seconds , then I put the connections on the right way.
JA: Have you tested the battery with a voltmeter? And can you see if it's leaking or not?
Customer: I installed new batteries & I crossed the last connections wrong & they sparked for about 3 seconds, then I put the connections on the right way, now I put the cart in gear and it will not move the cart either way. Did I blow a fuse or did I burn a wire connection? Dave
JA: What is the model/year of your electric?
Customer: 1999 EZGO electric cart
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: It doesn't run either way and I don't what to do. Are there any fuses
JA: Anything else you want the mechanic to know before I connect you?
Customer: I don't know anything else to tell him.
Submitted: 2 months ago.
Category: Electric Vehicles
Expert:  Pete replied 2 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Crossing wiring like this here can actually damage the control unit/ecu for the vehicle here.I dont show the exact specifics on your model here but there should be a control unit/ecu that controls electronics and operation of this model here.I have run into this on several models in the past before when the wiring was crossed like this here.

I would locate and check all fuses to make sure all are o.k.Try disconnecting the batteries for about 5 minutes then reconnect them and see if it operates.If this does not work and all fuses are good you will have to have this checked into/tested further to see if a control unit/ecu is at fault needing replaced to resolve this.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Expert:  Daniel Wilson replied 2 months ago.

Hi my name is***** will be glad to help. It really depends on the way you improperly hooked up the cables on whether you caused a short to ground or if you put too much voltage or amperage to the electrical components causing failure. the fuses and breakers on these carts in most cases will protect the major components from this . Let me know the complete model and serial number from the ID tag and I will be glad to try to pull up some diagrams for you for your cart model. Let me know

Expert:  Daniel Wilson replied 2 months ago.

Hi, Did you get this resolved?