How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Other
Category: Electric Vehicles
Satisfied Customers: 27458
Experience:  Worked on fleet of various electric vehicles, golf carts, scissor lifts and electric booms.
30244710
Type Your Electric Vehicles Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I just got an electric ezgo electric. Used it once and

Customer Question

I just got an electric ezgo electric. Used it once and charged over night. Did not work next day. No charger light even. Battery says 80%
Submitted: 6 months ago.
Category: Electric Vehicles
Expert:  Curtis B. replied 6 months ago.

Thanks for giving me the opportunity to work with you! I will do my best to help.

Expert:  Curtis B. replied 6 months ago.

Model and year? 36 or 48 volts? Do you ave a voltmeter to test battery pack and each battery and cable? Charger does not come on? If not, there is a break in the primary circuit, charger to batteries, through batteries, back to charger.

Customer: replied 6 months ago.
2016 rxv
Customer: replied 6 months ago.
All batteries show 80%
Expert:  Curtis B. replied 6 months ago.

That is what gage on dash shows. What is voltage at each battery? Does charger come on?

Expert:  Curtis B. replied 6 months ago.

Are these original batteries? You say 2016?

Customer: replied 6 months ago.
Dash shows 80% as does my battery tester. Don't have voltage reader. When changer in no light on charger. Horn and light works. Only went a few miles in first use
Expert:  Curtis B. replied 6 months ago.

with charger not coming on, there is a break in the primary circuit!

Customer: replied 6 months ago.
Is there a fuse anywhere that could be causing. Hard to believe working and then plugging in not
Expert:  Curtis B. replied 6 months ago.

RCV has electric brake, does the brake release when you go to drive? I see no fuse in the RXV circuit, and if charger does not come on, there is no voltage showing at the charger pug.

Customer: replied 6 months ago.
It does not release. Have tried rocking and nothing
Expert:  Curtis B. replied 6 months ago.

Another sign the voltage is not there. You have a break in the 48 volt circuit.

Customer: replied 6 months ago.
I assume you are saying needs to go to shop
Expert:  Curtis B. replied 6 months ago.

no, I'm saying you need to check each cable connection, between the charger connection, through the battery pack, and back to the charger plug. You have a bad connection or broken cable.

Customer: replied 6 months ago.
Ok will check out. I have wiggled each cable
Expert:  Curtis B. replied 6 months ago.

OK>

Customer: replied 6 months ago.
Check all wires connections,tighten all bolts checked all fuses and nothing
Expert:  Curtis B. replied 6 months ago.

You don't have access to a voltmeter, to check voltages?

Customer: replied 6 months ago.
No
Expert:  Curtis B. replied 6 months ago.

When charger is attached to cart, there is a switch in the charger side plug, that kills the electrical circuit, so cart will not drive if charger is attached. If this switch does not close when charger is removed, you have a dead cart. It has to power the keyswitch. Maybe this switch is open. Try plugging and unplugging the charger .

Customer: replied 6 months ago.
That did not work
Expert:  Curtis B. replied 6 months ago.

Without a voltmeter, to see where voltage is lost, looks like a trip to the cart shop!

Expert:  Curtis B. replied 6 months ago.

I see question is still open, did you find problem?