How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Other
Category: Electric Vehicles
Satisfied Customers: 26056
Experience:  Worked on fleet of various electric vehicles, golf carts, scissor lifts and electric booms.
30244710
Type Your Electric Vehicles Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a 2006 EZ Go TXTPDS. 36v I am installing a new Curtis

Customer Question

I have a 2006 EZ Go TXTPDS. 36v
I am installing a new Curtis 1268 500amp controller , heavy duty solenoid and a plum quick motor. I have everything installed and the cart moves about 10' and then stops. The LED code on the controller is 2-1 which indicates low battery voltage. The batteries were fully charge before beginning this modification.
I hope you can help!
Thanks Eddie
Submitted: 3 months ago.
Category: Electric Vehicles
Expert:  Curtis B. replied 3 months ago.

What does voltmeter show for battery voltage? If you attach the charger ,does it come on and charge?

Customer: replied 3 months ago.
I have 37.6 V. Charger is not picking up.
Customer: replied 3 months ago.
Just found the - for the charger disconnected. I have the charger picking up now.
Expert:  Curtis B. replied 3 months ago.

Charger not picking up means the primary circuit is not complete. Charger port to battery pack, through battery pack and back to the charger port. You have a break in this circuit.

Customer: replied 3 months ago.
Charger is now picking up and charging. The controller is still giving me the same code on the LED display.
Expert:  Curtis B. replied 3 months ago.

Do you have full pack voltage to the solenoid, and the controller, and the drive motor.

Customer: replied 3 months ago.
I have 36v on both sides of the solenoid. Also have 36v to A1 and A2 on the motor?????
Expert:  Curtis B. replied 3 months ago.

Test battery voltage while you move the cart and it quits/ See if voltage drops off. You may need to charge unit overnight.

Customer: replied 3 months ago.
Voltage is still good even when the cart stops 37.8 now
Customer: replied 3 months ago.
Why would M- on the controller and A2 on the motor be showing 36v ? Is this correct?
Expert:  Curtis B. replied 3 months ago.

M- comes direct from the solenoid, and would have voltage. I see the new controller is voltage sensitive, and you can NOT route cables too close to the M- terminal. ???

Customer: replied 3 months ago.
I have M- connected to A2 this comes from motor to controller
Battery pack + going to solenoid then from solenoid to B+ then from B+ to the motor A1
Battery pack - going to B- on the controllerF1&F2 go from controller to motor. Both are labeled.
Customer: replied 3 months ago.
Would you please walk me through the cable connections to make sure I'm connected correctly.
Expert:  Curtis B. replied 3 months ago.

Looks right to me, using the manual and page 8 in the manual, But has the low voltage setting been programed into the unit? If low voltage cutout is too high, it may be tripping and cutting out the unit. After reading the manual, I think that is what is going on. Low voltage cutout is too high, or has not been set.

Expert:  Curtis B. replied 3 months ago.

I see question is still open, dd you find the solution? Please use 5 star rating system to close.