How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete, Technician
Category: Electric Vehicles
Satisfied Customers: 24164
Experience:  17 years automotive training and experience.
Type Your Electric Vehicles Question Here...
Pete is online now
A new question is answered every 9 seconds

I have what I believe is a 36 volt 94 club car with the

Customer Question

I have what I believe is a 36 volt 94 club car with the exposed coil resistors. they all look good but the cart does not start off slow but seems to jump to "second gear" when you depress the pedal. you also have to depress the pedal further that it used to be to start off. I checked the coils and there do not seem to be any breaks in any of them. the cart runs good through the rest of the pedal travel.
JA: Does the engine turn over? How old is the battery?
Customer: This is a electric and the batteries are only oone year old and are fully charged.
JA: What year is your Volt?
Customer: Serial number is ***** 247335 and I was told it is a 94.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes I am and I did take the cover off of the speed control switch and it looks ok but I was going to remove all ov the electrical connections and cleand them.
JA: Anything else you think the mechanic should know?
Customer: Nothing other than this just started doing this and I did check the first resistor coil and did not see any break in it.
Submitted: 3 months ago.
Category: Electric Vehicles
Expert:  Pete replied 3 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

From what you have described here this sounds like a possible electronic fault with the pedal/throttle switch as most models use.I have seen this switch fail in the past before with the switch needing replaced.If this has not been checked into this needs done.If this is the switch you were going to try and clean the contacts on let me know if that corrected the fault here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,a rating of 4 or 5 is apprectiated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete