How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Other
Category: Electric Vehicles
Satisfied Customers: 25679
Experience:  Worked on fleet of various electric vehicles, golf carts, scissor lifts and electric booms.
Type Your Electric Vehicles Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Cart will not run no power at solenoid when key is on hot

Customer Question

Cart will not run no power at solenoid when key is on hot wired solenoid still will not run plugged in charger red light blinking
JA: Sometimes things that you think will be really complicated end up being easy to fix with an electric. The Electric Vehicle Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so he can help you best.
Customer: W
JA: Are you hoping to fix this yourself?
Customer: When we got cart it would run a week later you stop will not run let sit for an hour fire back up finally just quit
JA: Is there anything else important you think the Electric Vehicle Mechanic should know about your electric?
Customer: Got some trouble shooting info from ezego tried it all got no rev beeper did work
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Electric Vehicle Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Electric Vehicles
Expert:  Curtis B. replied 5 months ago.

Charger does not come on when attached to cart? Do you have a voltmeter to check the unit? If charger does not come on. there is a break in the primary circuit. The charger connection, to the battery pack, through the battery pack, and back to the charger plug. You say no voltage to the solenoid? The posiitve battery cable from the battery pack goes direct to the solenoid. I think you have a bad cable or a bad battery stopping all voltage. See attached diagram.

Expert:  Curtis B. replied 4 months ago.

Did you find problem? Bad battery or connection?