How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Electric Vehicles
Satisfied Customers: 24729
Experience:  17 years automotive training and experience.
14928985
Type Your Electric Vehicles Question Here...
Pete is online now
A new question is answered every 9 seconds

Electric Vehicles 2002: I have a 2002 e825 I had a bad

Customer Question

hi
I have a 2002 e825
I had a bad controller and replaced it
still the round dash gauge don't work all the lights and accessories do work
when I use the volt meter from the fuse to the red/white small wire on the contactor the dash lights up but still does not work
the contactor don't work I have 72 volts on the fuse side when I test
out side 72 volt
small red/white 5.4 volts
small green 12.4 volts
quiq charger does not give me percent of charge and some times im getting a code 1 and sometimes a code 2
all batteries are at 12.9-13 volts
i can not find a relay anywere
and were is the PWB board?
Submitted: 7 months ago.
Category: Electric Vehicles
Expert:  Pete replied 7 months ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know. I apologize that my info is limited here.If you have not checked for any loose,damaged or corroded wiring this can cause an issue like this here in some cases and should be checked into to see if a fault is found with the wiring needing repaired or replaced.If you have checked and found this to be o.k. let me know so we can continue here. If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.Thanks Pete
Customer: replied 7 months ago.
hi I sent a list of some of the things I check and some of the readings the answer I received said nothing
Expert:  Pete replied 7 months ago.
Unfortunately this is all of the info I have on this myself here.I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.Thanks Pete
Customer: replied 7 months ago.
thank you very much
Keith
Customer: replied 7 months ago.
hi pete yes I even opened the harness and also did a lot of continuity testing