How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Other
Category: Electric Vehicles
Satisfied Customers: 26016
Experience:  Worked on fleet of various electric vehicles, golf carts, scissor lifts and electric booms.
30244710
Type Your Electric Vehicles Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Sir I have an EZGO 2005 that I am having issues with. Found

Customer Question

Sir I have an EZGO 2005 that I am having issues with. Found some info on a blog that describes my issue exactly as the other guy, really odd. I recently backed the cart out of the garage and removed and cleaned all posts, load tested all the batteries individually, seemed like no issues. Put all the cables back in place, made sure they were correct, and lightly washed off all the batteries of dust and dirt. Went to put the cart away and nothing. Same thing as the other gentleman described. Checked all terminals on controls, ect, indicated nothing loose or disconnected. Checked the solenoid and it wasn't clicking. Ordered a new solenoid, installed, turned on the key, pressed pedal and witnessed a flash and puff of smoke from the left side smaller terminal on the solenoid and again obviously nothing. Any suggestions?
Submitted: 8 months ago.
Category: Electric Vehicles
Expert:  Curtis B. replied 8 months ago.

First see if the charger will come on when attached to cart. If not, you have a problem in the primary circuit, the wires from charger, through the batteries, back to the charger. Do you get any indication that you have voltage to the key switch?

Customer: replied 8 months ago.
I will check both tomorrow and respond.
Expert:  Curtis B. replied 8 months ago.

OK> Thanks.

Expert:  Curtis B. replied 8 months ago.

diagram

Customer: replied 8 months ago.
Curtis going out now to check the key voltage availability and whether the charger runs. However this diagram doesn't appear to represent the correct controller. My controller is a Curtis 25864G09, Ser # *****
Expert:  Curtis B. replied 8 months ago.

That is the Ezgo number for the Curtis 1206 controller, from what I see it is the same. ??

Customer: replied 8 months ago.
The cart I have is Model TXTE Date Code C0805 Ser#(###) ###-#### ***** controller has 5 pins and three buss logs. Here are some pictures. BTW the charge does activate and charges seamingly fine. I am in the process of checking voltage on the
key.
Customer: replied 8 months ago.
there is 36.5 V to the switch while off on positive side terminal. 36.5 V while switch is in the on position both terminals.
Customer: replied 8 months ago.
That diagram you sent is correct. I just couldn't see terminals J1,J3, J4, or J5, but the diagram I believe now is correct. J2 is the only visible terminal.
Expert:  Curtis B. replied 8 months ago.

OK does the solenoid close when pedal is pushed?

Expert:  Curtis B. replied 8 months ago.

There is a micro switch under the drivers mat, under a cover, That should energize the solenoid when pedal is pushed.

Customer: replied 8 months ago.
No it doesn't. But the switch tests continuity while pedal is depressed.
Customer: replied 8 months ago.
How can I test the coil (ITS) in the pedal box?
Customer: replied 8 months ago.
I am leaving here now, return several hours. May have to continue next weekend, ok?
Expert:  Curtis B. replied 8 months ago.

Did you have voltage to the foot micro?

Expert:  Curtis B. replied 8 months ago.

Here is link showing the tests for ezgo, scroll down the opening page to find the ITS test.

Customer: replied 8 months ago.
That link takes me to a Jacobson website, I don't see anything about golf carts on it, unless I am overlooking something.
Expert:  Curtis B. replied 8 months ago.

Just scroll down the page, do not go to the manual link!

Customer: replied 8 months ago.
Sorry.
Expert:  Curtis B. replied 8 months ago.

Did you find it?

Customer: replied 8 months ago.
sir. I will have to resume the testing next weekend.
Expert:  Curtis B. replied 8 months ago.

OK< thanks,

Customer: replied 8 months ago.
Thank you for your help the last two days. I will get a hold of you next time I can get back on it. Have a great week.
Expert:  Curtis B. replied 8 months ago.

You too! I'm, going to take a few days off next week myself!

Expert:  Curtis B. replied 8 months ago.

Just checking back. Have you had a chance to work on cart?