How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cardoctor71 Your Own Question
Cardoctor71
Cardoctor71, ASE Master Technician
Category: Electric Vehicles
Satisfied Customers: 672
Experience:  35 years experience in the automotive and Lt truck repair business, owner Cardoctor LLC Guthrie, OK
36867192
Type Your Electric Vehicles Question Here...
Cardoctor71 is online now
A new question is answered every 9 seconds

I have a EZ-GO cart that has been tricked out somewhat and

Customer Question

I have a EZ-GO cart that has been tricked out somewhat and has been working great until just recently. It has 4 12v batteries. 3 across and 1 cross ways behind. The one behind is the problem. The terminals are corroding and the battery seems to be overheating or something when charging causing water leaking out the top. I replaced one of the cables awhile back because the terminal end was partially gone. It seemed to be OK for awhile but then the same thing happened again and then the cart will not operate. I made sure that the terminals were tight. What do you think is causing this problem?
Thank you for your help, Neil Boardman
Submitted: 1 year ago.
Category: Electric Vehicles
Expert:  Cardoctor71 replied 1 year ago.

The battery plates inside the battery are oxidized, and the battery will have to replaced,PLEASE RATE my service a 3 or above, if for some reason you can not, PLEASE ask me another question, I will continue to answer your questions even after you rate my service until you are completely satisfied with my answers.

Customer: replied 1 year ago.
I guess that I don't completely understand. Is it unusual for just one battery to be a problem? Why did it seem to work OK before, after I cleaned up the terminals and replaced that one cable. Do I need to do something with the other batteries? What other maintenance do I need to do? I don't have an owners manual or service manual or anything. Is it possible to get a manual?
Thank you, Neil
Customer: replied 1 year ago.
I guess that I don't completely understand. Is it unusual for just one battery to be a problem? Why did it seem to work OK before, after I cleaned up the terminals and replaced that one cable? Do I need to do something with the other batteries? What other maintenance do I need to do? I don't have an owners manual or service manual or anything. Is it possible to get a manual?
Thank you, Neil
Customer: replied 1 year ago.
I did request more information twice, once on 10/16 and again on 10/18 but I didn't get a reply. My response was as follows.I guess that I don't completely understand. Is it unusual for just one battery to be a problem? Why did it seem to work OK before, after I cleaned up the terminals and replaced that one cable? Do I need to do something with the other batteries? What other maintenance do I need to do? I don't have an owners manual or service manual or anything. Is it possible to get a manual?Thank you, Neil