How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Electric Vehicles
Satisfied Customers: 24697
Experience:  17 years automotive training and experience.
14928985
Type Your Electric Vehicles Question Here...
Pete is online now
A new question is answered every 9 seconds

2009 Ezgo RXV: Sometimes will go, sometimes it won't. I just

Customer Question

2009 Ezgo RXV: Sometimes will go, sometimes it won't. I just get trying Forward and Reverse until it goes
Submitted: 1 year ago.
Category: Electric Vehicles
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

My info is limited on your model here but I see no one else has responded and thought I would see if I can help here.

This may be due to a control switch that sends signals to operate the vehicle in forward or reverse being faulty needing replaced.I have seen in some cases where a control switch can fail and cause an issue like this here needing replaced.This will have to be checked into/tested further to be sure and repaired from there.The wiring from the switch and to the motor will also need checked to see if any wiring is found damaged or broken in any way.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Thanks Pete.

Customer: replied 1 year ago.
For whatever reason, when the pedal cover is on, it acts up, whenever it is off it runs fine. Have no idea what this could be
Customer: replied 1 year ago.
I need some more input. I don't intend on paying $28 for this kind of effort