How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Other
Category: Electric Vehicles
Satisfied Customers: 27470
Experience:  Worked on fleet of various electric vehicles, golf carts, scissor lifts and electric booms.
30244710
Type Your Electric Vehicles Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Electric Vehicles ez go freedom: I'm Al. I have a 1999

Customer Question

Hello I'm Al.
I have a 1999 ezgo freedom 36v.
New batteries
Clicks when depressing accelerator
But doesn't move.
New soluble and fnr
Took motor out brushes look good.
And it get voltage to motor
ITS switch reads twit meter.
0 or full volts.
I'm lost think it may be controller or motor.
Is there away to ck motor to jump it straight off batteries to rule it out or what are ur thoughts.
Submitted: 1 year ago.
Category: Electric Vehicles
Expert:  Curtis B. replied 1 year ago.
is solenoid closing? bypass the solenoid and try it.
Expert:  Curtis B. replied 1 year ago.
http://mrcarts.com/cat_ezgo_technical_info.cfm
Expert:  Curtis B. replied 1 year ago.
Go to MR carts site, and scroll down to find the motor test.
Customer: replied 1 year ago.
Not sure about solinoide closing
On the rt and lf large wires it reads 1.5
Until I depress the gas pedal then instantly goes to 0
Expert:  Curtis B. replied 1 year ago.
Solenoid should have 36 volts on both sides.
Customer: replied 1 year ago.
I'm getting 38.9 on both sides of the front small solinoide bolts.
I'm working thru this. I'm a car mech. And this is slightly outta my league.
And thank u very much.
Expert:  Curtis B. replied 1 year ago.
Thank you!
Customer: replied 1 year ago.
Any thoughts on the difference in voltage.
Or could it b the power controller.
Also one more thing just found out.
Last yr. The kids drove it home...about 2 miles with the left side tire locked up.
Like dragging one leg. Then it never started again.
Expert:  Curtis B. replied 1 year ago.
Does charger come on? Do you have 36 volts on both large post of the solenoid? Did you look at the Mr Carts site, showing all the tests!
Customer: replied 1 year ago.
The large bolts are reading 1.5 v lf and rt
And since I'm at a camp site I'm unable to see the mr. cart site. I only have 2bars.
Thanks
Expert:  Curtis B. replied 1 year ago.
Check all the battery connections, looking for a broken cable or connection. Follow the cables back from the solenoid, looking for a break in the circuit.