How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, Chrysler/Dodge/Jeep master tech
Category: Dodge
Satisfied Customers: 22535
Experience:  ASE Master and Advanced Certified, Chrysler/Dodge/Jeep Master Certified, Trans and Hybrid Specialist
9825021
Type Your Dodge Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

My 2003 2500 the trailer lights plug doesn't work. i read

Customer Question

my 2003 2500 the trailer lights plug doesn't work. i read about relays that are in the interior of the fuse box go bad. instead of opening the box up i replaced it with a used one i purchased. still the trailer light plug doesn't work. what else can i check? all wires are in tact that i can see
JA: How many miles are on the car? Has the car been starting normally?
Customer: 73000 it starts right up. sometimes i notice the smallest delay in ignition but barely noticeable
JA: Are you fixing your 2500 yourself? What have you tried so far?
Customer: i replaced the fuse box with a used one i found online. supposedly guaranteed
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 7 months ago.
Category: Dodge
Expert:  sprinkles08 replied 7 months ago.

Hello and welcome to JustAnswer!

There are a few things that could be going on depending on exactly what symptoms you're experiencing. The most likely cause for something in the trailer connector not working would be a wiring issue.

What function isn't working?
Is this the four way, seven way or both?

Do all lights on the truck work correctly?

Customer: replied 7 months ago.
all lights work. The four way and seven way don't don't work
Expert:  sprinkles08 replied 7 months ago.

What function is not working?

Customer: replied 7 months ago.
All lights on the truck work. The four way and seven way trailer connector do not work
Expert:  sprinkles08 replied 7 months ago.

What function on the trailer connectors does not work?

Customer: replied 7 months ago.
All of it doesn't work. No signals at all. No lights etc. I am not getting any power at all to either connector
Expert:  sprinkles08 replied 7 months ago.

You've verified each circuit does nothing using an incandescent test light at the connectors?

Customer: replied 7 months ago.
I hooked it up to a trailer that works off my other trucks and I have a 7 way plug in light tester as well. Getting no power at all
Expert:  sprinkles08 replied 7 months ago.

Using something that plugs into the connector or a trailer doesn't give you any useful information for individual circuits and isn't a substitute for actual testing. If you were missing ground then nothing on a trailer would work but that doesn't mean there is no power to any of the circuits.

You need to start by connecting the alligator clip of an incandescent test light to a good ground and test the park light and brake/turn circuits for power with the appropriate lights turned on and see if the test light lights up. If so then connect the alligator clip to battery positive and test the ground.

Customer: replied 7 months ago.
A local mechanic gave me his trailer plug tester. It's a 7 way tester. It lights up when plugged in to the 7 way and any trailer functions are in use. It works on all my other trucks but this one. Serves the same function as a tester light
Expert:  sprinkles08 replied 7 months ago.

It isn't the same as a test light whatsoever and isn't useful other than trying to differentiate if a problem is on a trailer or the vehicle, and even in then it isn't accurate if it uses LED's. It uses the ground in the connector and if that ground is missing then the tester isn't going to work. If you're attempting to diagnose the problem yourself then the first steps in doing so are what I described.

Customer: replied 7 months ago.
Ok I will try that
Expert:  sprinkles08 replied 7 months ago.

Let me know what you find and we can go from there.

Customer: replied 7 months ago.
Will do
Expert:  sprinkles08 replied 7 months ago.

Great!

Customer: replied 7 months ago.
Put a test light on 7 way and 4 way. Got nothing
Expert:  sprinkles08 replied 7 months ago.

You tested exactly as I described and no wire in any connector lights the test light at any time? The only possible cause would be every wire is broken somewhere in the harness.

Customer: replied 7 months ago.
I just unplugged the wire harness from behind the 7 way and tested the wire harness and got power. So I guess the plug is bad
Expert:  sprinkles08 replied 7 months ago.

Yes, that issue is in the connector.

Customer: replied 7 months ago.
Ok thanks
Expert:  sprinkles08 replied 7 months ago.

You're welcome!