How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Your Own Question
Chad
Chad, Lead Master Tech
Category: Dodge
Satisfied Customers: 1114
Experience:  Electrical Master,Diesel Specialist, Lead Tech/shop foreman
12781541
Type Your Dodge Question Here...
Chad is online now
A new question is answered every 9 seconds

I have all kind of light in dash no rpm no gage working

Customer Question

I have all kind of light in dash no rpm no gage working trailer light flashing wiper working all the time signal light not working and 4x4 not working I have code for communication u0431/uo43100/u0010/uo141/u0184 I have disconnect all module one by one no luck any ideal
JA: Have you checked the fuses? The dashboard bulbs?
Customer: yes
JA: What is the model/year of your Dodge?
Customer: 2010ram 2500 5.7 liter
JA: What year is your 2500?
Customer: 2010
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: try to disconnect some module
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 5 months ago.
Category: Dodge
Expert:  Chad replied 5 months ago.

U0431 - No communication with TIPM

u0010 - No interior BUS

You say you have disconnected all the modules and no luck.

Did you have a scan tool connected while you performed this?

Expert:  Chad replied 5 months ago.

From everything you stated, I suspect the TIPM has died.

I would replace TIPM.